1 Reply Latest reply on Jul 20, 2011 8:28 PM by bjen mat

    a4j:commandbutton not working in ui: repate wihtin rich:popuppanel

    bjen mat Newbie

      hello every one,

       

      i am using richfaces 4.0 final version along with jsf 2.0 , am trying to get values of a list by iterating using ui:repeat in a rich:popuppanel after i click a a4j:command button. The list gets rendered and i have a check box and a a4j:commandbutton in the list, now i want to carry out some action when clicked in the checkbox or the a4j:commandbtton, how ever neither of it works. Also in the same rich:popuppanel when i place another a4j:commandbutton which is outside the ui:repeat tag , the a4j:command button works. I have found a similar post in this forum regarding the same situation however could not find the answer the link for the previous similar post is : ' http://community.jboss.org/message/543060#543060 ' .

       

      I'm stuck with the problem and need to find the solution, any help ?

       

      Here is the test example where i have generated the same situation : i've attached the xhtml file and src file here

       

      Actually  the manged bean in request scope and the ui:repat is generated after clicking a4j:command button, it seems like the a4j:command button within the ui:repeat doesn't maintains its state when used in request scope but it works in session scope, however my requirement is in request scope, i've tried to use binding with the a4j:command button however setting the setrendered() method true too doesnt work, how can this be solved ?

       

       

      any answers !!!!

       

      Message was edited by: bjen mat