2 Replies Latest reply on Jul 15, 2011 7:19 AM by Rob Stryker

    Problem setting jdk

    Rene Felder Newbie

      I'm not able to set the jdk for JBoss 7 when creating the JBoss 7 server runtime. The problem is that I use different runtimes in Eclipse so I also need jdk 5.0. It seems that the server runtime for jboss 7 uses the first jdk that it can find from 'Installed JRE's'.

       

      Is there a way I can define the choosen runtime for jboss 7? I'm using the latest milestone of jboss tools that is available! It would be ok to define the runtime within a configuration file within eclipse .metadata but I did not find any! Don't know wheter this is of interest, but I'm using Mac OS X.

        • 1. Re: Problem setting jdk
          Max Rydahl Andersen Master

          You are right - just checked latest and AS7 seem to hide the previous UI for choosing exeuction environment - thats a bug.

           

          Opened here:

          https://issues.jboss.org/browse/JBIDE-9349

          • 2. Re: Problem setting jdk
            Rob Stryker Master

            AS7 was missing the section where it set its default execution environment. It was therefore set to JavaSE-1.4 instead of 1.6. This means your version 5 JRE would be acceptable.

             

            I've updated the critical issue for the creation of a new JBoss 7 Runtime... but you probably have to delete the current server and runtime and recreate

            them from scratch. This was a big overlook on my part.

             

            Adding in the ability to "choose" a jdk can be added, but maybe a bit later. For now I've fixed the critical issue, and the execution environment is now correct. Your version 5 jre / jdk should be ignored and not chosen now for launching as7. 

            =]