1 Reply Latest reply on Jul 21, 2011 9:18 AM by jaikiran pai

    Google Inspecting JBoss MBeans

    Mike Duffy Newbie

      Started from another thread:  http://community.jboss.org/thread/169713?tstart=0

       

      I am getting the following error running a fresh instance of JBoss 6.0 Final on my home server:

       

      07:07:34,735 ERROR [org.apache.catalina.core.ContainerBase.[jboss.web].[localhost].[/jmx-console].[HtmlAdaptor]] Servlet.service() for servlet HtmlAdaptor threw exception: javax.management.MalformedObjectNameException: Invalid character ':' in value part of property

              at javax.management.ObjectName.construct(ObjectName.java:602) [:1.6.0_26]

              at javax.management.ObjectName.<init>(ObjectName.java:1403) [:1.6.0_26]

              at org.jboss.jmx.adaptor.control.Server.getMBeanData(Server.java:97) [:]

              at org.jboss.jmx.adaptor.html.HtmlAdaptorServlet$1.run(HtmlAdaptorServlet.java:357) [:]

              at org.jboss.jmx.adaptor.html.HtmlAdaptorServlet$1.run(HtmlAdaptorServlet.java:354) [:]

              at java.security.AccessController.doPrivileged(Native Method) [:1.6.0_26]

              at org.jboss.jmx.adaptor.html.HtmlAdaptorServlet.getMBeanData(HtmlAdaptorServlet.java:353) [:]

              at org.jboss.jmx.adaptor.html.HtmlAdaptorServlet.inspectMBean(HtmlAdaptorServlet.java:224) [:]

              at org.jboss.jmx.adaptor.html.HtmlAdaptorServlet.processRequest(HtmlAdaptorServlet.java:100) [:]

              at org.jboss.jmx.adaptor.html.HtmlAdaptorServlet.doGet(HtmlAdaptorServlet.java:81) [:]

              at javax.servlet.http.HttpServlet.service(HttpServlet.java:734) [:1.0.0.Final]

              at javax.servlet.http.HttpServlet.service(HttpServlet.java:847) [:1.0.0.Final]

              at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:324) [:6.0.0.Final]

              at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:242) [:6.0.0.Final]

              at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:275) [:6.0.0.Final]

              at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191) [:6.0.0.Final]

              at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:181) [:6.0.0.Final]

              at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:88) [:6.0.0.Final]

              at org.jboss.web.tomcat.security.SecurityContextEstablishmentValve.invoke(SecurityContextEstablishmentValve.java:100) [:6.0.0.Final]

              at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127) [:6.0.0.Final]

              at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102) [:6.0.0.Final]

              at org.jboss.web.tomcat.service.jca.CachedConnectionValve.invoke(CachedConnectionValve.java:158) [:6.0.0.Final]

              at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:567) [:6.0.0.Final]

              at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109) [:6.0.0.Final]

              at org.jboss.web.tomcat.service.request.ActiveRequestResponseCacheValve.invoke(ActiveRequestResponseCacheValve.java:53) [:6.0.0.Final]

              at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:362) [:6.0.0.Final]

              at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:877) [:6.0.0.Final]

              at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:654) [:6.0.0.Final]

              at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:951) [:6.0.0.Final]

              at java.lang.Thread.run(Thread.java:662) [:1.6.0_26]

       

      It was very weird that this error was occurring about every 55 minutes.

       

      Someone suggested, "Enable the AccessLogValve in JBOSS_HOME/server/<servername>/deploy/jbossweb.sar/server.xml:"

       

      Enabling my AccessLogValve was a great suggestion.

       

      Here is the entry that triggered the error:

       

      66.249.72.27 - - [21/Jul/2011:07:07:34 -0500] "GET /robots.txt HTTP/1.1" 404 983

      66.249.72.27 - - [21/Jul/2011:07:07:34 -0500] "GET /jmx-console/HtmlAdaptor?action=inspectMBean&name=jboss.web%3Atype%3DConnector%2Cport%3D8009%2Caddress%3D%252F192.168.1.108%3Ejboss.web:type=Connector,port=8009,address=%2F192.168.1.108%3C/a%3E%3C/p%3E%20%20%20%20%3C/pre%3E%20%20%20%3C/td%3E%20%20%3C/tr%3E%20%20%3Ctr%3E%20%20%20%3Ctd%20class= HTTP/1.1" 500 822

       

      If you do a WhoIs lookup on 66.249.72.27 the owner of the IP address is Google.

       

      Why is Google trying to inspect one of my JBoss MBeans???

       

      Is this a good thing or a bad thing???

       

      If it helps index my website, then perhaps it is a good thing.

       

      It's a little bit scary that Google (or anyone else) was able to get the IP address of my workstation on my internal home network.  Is this a security flaw in JBoss or perhaps a misconfig on my Linksys router?

       

      Can anyone tell me what is really going on???