3 Replies Latest reply on Jul 28, 2011 3:52 PM by Peter Johnson

    NullpointerException while building in Hudson

    Arka Sharma Newbie

      Hi,

       

      I am having following errors at hudson console while building a project.The build is being failed.Errors are as follows

       

      ERROR: Processing failed due to a bug in the code. Please report this to dev@hudson.java.net

      java.lang.NullPointerException
      at hudson.FilePath.isAbsolute(FilePath.java:225)

      at hudson.FilePath.<init>(FilePath.java:212)

      at hudson.FilePath.child(FilePath.java:896)

      at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:554)

      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:429)

      at hudson.model.Run.run(Run.java:1363)

      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:405)

      at hudson.model.ResourceController.execute(ResourceController.java:88)

      at hudson.model.Executor.run(Executor.java:145)

      project=hudson.maven.MavenModuleSet@4551de[Mach]

      project.getModules()=[hudson.maven.MavenModule@3d4258[Mach/mach:captive-portal][Mach/mach:captive-portal][relativePath:null], hudson.maven.MavenModule@14e628c[Mach/mach:dre-ear][Mach/mach:dre-ear][relativePath:null], hudson.maven.MavenModule@b2e90[Mach/mach:mach-portal-buisinesslogic][Mach/mach:mach-portal-buisinesslogic][relativePath:null], hudson.maven.MavenModule@1367406[Mach/mach:sdp-root][Mach/mach:sdp-root][relativePath:C:\maven_build\mach], hudson.maven.MavenModule@1fb69d3[Mach/mach:sdp-statemachine][Mach/mach:sdp-statemachine][relativePath:null]]

      project.getRootModule()=hudson.maven.MavenModule@1367406[Mach/mach:sdp-root][Mach/mach:sdp-root][relativePath:C:\maven_build\mach]

      FATAL: null

      java.lang.NullPointerException
      at hudson.FilePath.isAbsolute(FilePath.java:225)

      at hudson.FilePath.<init>(FilePath.java:212)

      at hudson.FilePath.child(FilePath.java:896)

      at hudson.maven.MavenModuleSetBuild$RunnerImpl.doRun(MavenModuleSetBuild.java:554)

      at hudson.model.AbstractBuild$AbstractRunner.run(AbstractBuild.java:429)

      at hudson.model.Run.run(Run.java:1363)

      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:405)

      at hudson.model.ResourceController.execute(ResourceController.java:88)

      at hudson.model.Executor.run(Executor.java:145)

       

      My project structure is like following

       

      mach

      |--pom

      |--ear

         |--pom

      |--mach-portal-businesslogic

         |--pom

      |--sdp-statemachine

         |--pom

      |--captive-portal

         |--pom

       

      sdp-statemachine building is being failed.Other's builds aren't even started.

       

      But when I build using maven thensdp-statemachine is building fine however captive-portal is being failed.

       

      Please give some idea since I am newbie to hudson,maven and JBoss.

       

      Thanks,

      Arka