4 Replies Latest reply on Aug 9, 2011 5:56 PM by Fred Bricon

    Relax the version requirement for m2e

    Fabricio Lemos Newbie

      me2 has a new version (1.1.1) that fix some bugs that are stopping me. Unfortunately Jboss Tools doesn´t work with this new version, even it being backwards compatible with version 1.0.

       

      Would it be possible to relax the version requirement for m2e?

       

      thanks,

      Fabricio Lemos

        • 1. Re: Relax the version requirement for m2e
          Fred Bricon Novice

          Fabricio,

           

          I'm not aware of a m2e 1.1.1 version, where did you get it? Latest milestone is 1.0.100, current dev builds are 1.0.200-SNAPSHOT

          JBT plugins for 3.2.1 (released a few days ago) and 3.3.0M3 (nightly builds) accept m2e version up to 1.1 (excluded)

          1 of 1 people found this helpful
          • 2. Re: Relax the version requirement for m2e
            Fabricio Lemos Newbie

            It was a typo, sorry. I´m trying to install m2e 1.0.100, wich was not possible with 3.3.0M2. I´m going to try with M3 nightly.

             

            thank you Fred

            • 3. Re: Relax the version requirement for m2e
              Fabricio Lemos Newbie

              With 3.3.0M3 nightly I have this error while installing m2e 1.0.100:

               

              Your original request has been modified.

                "m2e - Maven Integration for Eclipse" is already installed, so an update will be performed instead.

              Cannot complete the install because of a conflicting dependency.

                Software being installed: m2e - Maven Integration for Eclipse 1.0.100.20110804-1717 (org.eclipse.m2e.feature.feature.group 1.0.100.20110804-1717)

                Software currently installed: Forge Tools 1.0.0.v20110808-0409-H215-M3 (org.jboss.tools.forge.feature.feature.group 1.0.0.v20110808-0409-H215-M3)

                Only one of the following can be installed at once:

                  Embedded Maven Runtime Bundle 1.0.0.201106061504 (org.eclipse.m2e.maven.runtime 1.0.0.201106061504)

                  Embedded Maven Runtime Bundle 1.0.0.20110607-2117 (org.eclipse.m2e.maven.runtime 1.0.0.20110607-2117)

                  Embedded Maven Runtime Bundle 0.13.0.201105171436 (org.eclipse.m2e.maven.runtime 0.13.0.201105171436)

                  Embedded Maven Runtime Bundle 1.0.100.20110804-1717 (org.eclipse.m2e.maven.runtime 1.0.100.20110804-1717)

                Cannot satisfy dependency:

                  From: m2e - Maven Integration for Eclipse 1.0.100.20110804-1717 (org.eclipse.m2e.feature.feature.group 1.0.100.20110804-1717)

                  To: org.eclipse.m2e.maven.runtime [1.0.100.20110804-1717]

                Cannot satisfy dependency:

                  From: Forge Tools 1.0.0.v20110808-0409-H215-M3 (org.jboss.tools.forge.feature.feature.group 1.0.0.v20110808-0409-H215-M3)

                  To: org.jboss.tools.forge.ui [1.0.0.v20110808-0409-H215-M3]

                Cannot satisfy dependency:

                  From: Forge Tools 1.0.0.v20110808-0409-H215-M3 (org.jboss.tools.forge.ui 1.0.0.v20110808-0409-H215-M3)

                  To: bundle org.eclipse.m2e.maven.runtime [0.13.0,1.0.100)

              • 4. Re: Relax the version requirement for m2e
                Fred Bricon Novice

                Yeah the version range was improperly set in the forge plugin. My bad.

                I created https://issues.jboss.org/browse/JBIDE-9504 to follow up on that issue.

                Hopefully that should be fixed in the next CI build of 3.3.0 M3