0 Replies Latest reply on Aug 9, 2011 11:24 PM by Zemian Deng

    Is there newer slf4j-jboss-logmanager.jar that supports slf4j-1.6.x?

    Zemian Deng Apprentice

      Hello there,

       

      Currently the AS6 JBOSS_HOME/common/lib/slf4j-jboss-logmanager.jar is statically compiled with slf4j-api verison 1.5.6. This creates probme when deploying libraries that already compiled with slf4j-1.6.1 since their API is incompatible.

       

      I tried drop in slf4j-1.6.1 into the server, but then it will not accepts AS6's JBOSS_HOME/common/lib/slf4j-jboss-logmanager.jar as binding because it's from 1.5.x. I get errors such as this:

      23:08:13,625 ERROR [STDERR] SLF4J: slf4j-api 1.6.x (or later) is incompatible with this binding.

      23:08:13,625 ERROR [STDERR] SLF4J: Your binding is version 1.5.5 or earlier.

      23:08:13,625 ERROR [STDERR] SLF4J: Upgrade your binding to version 1.6.x. or 2.0.x

       

      So is there a newer version of slf4j-jboss-logmanager.jar that works with slf4j-1.6.1?

       

      Thanks,

      -Z