1 Reply Latest reply on Aug 17, 2011 11:00 PM by Jesus Salvo

    JBoss 5.1.0GA + upgraded Hibernate Validator ( from 3.1 to 4.1 ) for JSR-303 reference implementation

    Jesus Salvo Newbie

      Hi All,

       

      We are currently using JBoss 5.1.0 GA and won't be using JBoss 6.x.x until late next year. Now JBoss 5.1.0 GA has Hibernate Validator 3.1.0 GA. We would like to be able to use the JSR-303 reference implementation, which is Hibernate Validator 4.1.0 GA.

       

      So basically the questions is:

       

      Will replacing Hibernate Validator 3.1.0 GA with 4.1.0 GA break JBoss 5.1.0 GA ?

       

      Some additional info:

       

      We do not use JPA ( for historical and legacy reasons ), and currently still using Hibernate directly as we started using Hibernate long before JPA became a standard. I presume Hibernate ( the persistance manager ) .