9 Replies Latest reply on Sep 7, 2011 7:11 PM by mdpjhammett

    mod_cluster module makes Apache hang upon startup only with mod_ssl also enabled

    mdpjhammett Newbie

      Solaris 10 SPARC

      Apache/2.2.19 --with-mpm=worker --enable-nonportable-atomics=yes (also tried Apache/2.2.15)

      mod_ssl/2.2.19 (also tried mod_ssl/2.2.15)

      mod_cluster/1.0.10.GA_CP01 (also tried mod_cluster/1.1.2)

       

      If I telnet to the listen port it connects but never responds. If I disable mod_ssl OR disable mod_cluster it starts up fine. If I start it up as a single process using httpd -X it starts up fine. Here's the error log with debug enabled:

       

      [Wed Aug 10 13:51:45 2011] [debug] ssl_engine_init.c(415): Creating new SSL context (protocols: SSLv3, TLSv1)

      [Wed Aug 10 13:51:45 2011] [debug] ssl_engine_init.c(611): Configuring permitted SSL ciphers [ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:-LOW:+SSLv2:+EXP:+eNULL]

      [Wed Aug 10 13:51:45 2011] [debug] ssl_engine_init.c(742): Configuring RSA server certificate

      [Wed Aug 10 13:51:45 2011] [warn] RSA server certificate wildcard CommonName (CN) `dev.secure.*.*' does NOT match server name!?

      [Wed Aug 10 13:51:45 2011] [debug] ssl_engine_init.c(781): Configuring RSA server private key

      [Wed Aug 10 13:51:45 2011] [info] mod_ssl/2.2.15 compiled against Server: Apache/2.2.15, Library: OpenSSL/0.9.7d

      [Wed Aug 10 13:51:45 2011] [notice] Advertise initialized for process 2007

      [Wed Aug 10 13:51:45 2011] [notice] Apache/2.2.15 (Unix) mod_ssl/2.2.15 OpenSSL/0.9.7d configured -- resuming normal operations

      [Wed Aug 10 13:51:45 2011] [info] Server built: Jul 12 2011 17:11:56

      [Wed Aug 10 13:51:45 2011] [debug] worker.c(1757): AcceptMutex: pthread (default: pthread)

      <hangs here>

       

      I've tried different module and Apache versions (see above) and I've tried commenting out any nonessential directives in the config files. I tried shutting down another Apache instance using mod_cluster but not mod_ssl that is sharing the same binaries but this one still hangs. Any recommendation on what else to try? Apache configs are attached.