5 Replies Latest reply on Jun 28, 2012 5:09 AM by david delbecq

    jboss AS7 problem with struts 1.2

    Koti talla Newbie

      Hi All,

              I get the following error deploying my war file in the jboss AS7 , I have included the struts jar in WEB-INF /lib folder still I get  the following error

       

      16:58:49,401 INFO  [org.jboss.as.jpa] (MSC service thread 1-2) added javax.persistence.api dependency to accessms.war

      16:58:49,837 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-5) MSC00001: Failed to start service jboss.deployment.unit."accessms.war".INSTALL: org.jboss.msc.service.StartException in service jboss.deployment.unit."accessms.war".INSTALL: Failed to process phase INSTALL of deployment "accessms.war"

      at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:121)

      at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1765)

      at org.jboss.msc.service.ServiceControllerImpl$ClearTCCLTask.run(ServiceControllerImpl.java:2291)

      at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) [:1.7.0]

      at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [:1.7.0]

      at java.lang.Thread.run(Unknown Source) [:1.7.0]

      Caused by: org.jboss.as.server.deployment.DeploymentUnitProcessingException: Failed to load class org.apache.struts.taglib.template.GetTag

      at org.jboss.as.ee.component.EEClassConfigurationProcessor.deploy(EEClassConfigurationProcessor.java:95)

      at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:115)

      ... 5 more

      Caused by: java.lang.ClassNotFoundException: org.apache.struts.taglib.template.GetTag from [Module "deployment.accessms.war:main" from Service Module Loader]

      at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:191)

      at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:358)

      at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:330)

      at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:307)

      at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:101)

      at java.lang.Class.forName0(Native Method) [:1.7.0]

      at java.lang.Class.forName(Unknown Source) [:1.7.0]

      at org.jboss.as.ee.component.EEClassConfigurationProcessor.deploy(EEClassConfigurationProcessor.java:93)

      ... 6 more

       

       

      Please help,

       

      Thanks,

      Sekhar

        • 1. Re: jboss AS7 problem with struts 1.2
          jaikiran pai Master

          Are you sure that class is present in that jar and it's not missing some other jar file(s)?

          • 2. Re: jboss AS7 problem with struts 1.2
            Koti talla Newbie

            Thanks Kiran for the reply,

             

            Yes i have included the jar in lib folder of the war . The jar is struts.jar, to confirm I have downloaded struts-1.2.7-lib from apache site ( as we are using old version I have downloaded the old version and placed in the lib folder), this is what i get

             

             

            Caused by:

            java.lang.ClassNotFoundException

            : org.apache.struts.taglib.template.GetTag from [Module "deployment.accessms.war:main" from Service Module Loader]

            at org.jboss.modules.ModuleClassLoader.findClass(

            ModuleClassLoader.java:191

            )

             

            I have java 1.7 as the jre

            jboss AS7

             

            The same code works fine with jboss AS 5.1

            I read the Migration document , which says war is treated as separate deployment and jar which are needed are to be placed in /lib folder.

             

            Please advice.

             

            Thanks,

            Sekhar

            • 3. Re: jboss AS7 problem with struts 1.2
              david delbecq Newbie

              I have the same problem (application using struts 1.2). Did you find a solution?

               

              Caused by: java.lang.ClassNotFoundException: org.apache.struts.taglib.MessageTag from [Module "deployment.xwiki.war:main" from Service Module Loader]

                      at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:190)

                      at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:468)

                      at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:456)

                      at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:398)

                      at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:120)

                      at org.jboss.as.jaxrs.deployment.JaxrsComponentDeployer.deploy(JaxrsComponentDeployer.java:63)

                      ... 6 more

              • 4. Re: jboss AS7 problem with struts 1.2
                Stephen Coy Master

                You have an obsolete struts tld file embedded in your application somewhere.

                 

                MessageTag lives in package org.apache.struts.taglib.bean in Struts 1.2.

                • 5. Re: jboss AS7 problem with struts 1.2
                  david delbecq Newbie

                  Indeed, this was the problem.

                   

                  Thank you very much