1 Reply Latest reply on Sep 2, 2011 10:44 AM by Brian Leathem

    4.1.0 M1 jstl dependency bom change breaks Maven build

    u j Novice

      richfaces-bom-4.0.0-20110325.220425-300.pom has

      <dependency>
      <groupId>javax.servlet</groupId>
      <artifactId>jstl</artifactId>
      <version>1.2</version>
      </dependency>

      whereas richfaces-bom-4.1.0.20110805-M1.pom has

              <dependency>
                  <groupId>javax.servlet.jsp.jstl</groupId>
                  <artifactId>jstl-api</artifactId>
                  <version>1.2</version>
              </dependency>

       

      So my pom.xml with

      <dependency>
      <groupId>javax.servlet</groupId>
      <artifactId>jstl</artifactId>
      </dependency>

      stops working in 4.1.0 M1. I wonder if this change is on purpose or is it a bug.

       

      Thanks