1 Reply Latest reply on Oct 24, 2008 3:23 AM by Adam Warski

    envers-1.1.0.ga.jar seems to be for hibernate 3.3?

    talios Newbie

      Adam,

      Just tried envers-1.1.0.ga.jar and got the following exception:

      org.hibernate.MappingException: Could not find persister class: org.jboss.envers.entity.VersionsInheritanceEntityPersisterFor32
       at org.hibernate.cfg.HbmBinder.bindPersistentClassCommonValues(HbmBinder.java:642)
       at org.hibernate.cfg.HbmBinder.bindClass(HbmBinder.java:527)
       at org.hibernate.cfg.HbmBinder.bindRootClass(HbmBinder.java:271)
       at org.hibernate.cfg.HbmBinder.bindRoot(HbmBinder.java:144)
       at org.hibernate.cfg.Configuration.add(Configuration.java:675)
      


      The jar does however contain org.jboss.envers.entity.VersionsInheritanceEntityPersisterFor33 - I guess the wrong jar was uploaded?