3 Replies Latest reply on Aug 29, 2011 11:43 AM by Aslak Knutsen

    Glassfish 3.1 remote - WAR Permission denied

    Piotr Nowicki Newbie

      Howdy!

       

      I've bumped into some minor problem when deploying my app using arquillian glassfish 3 remote adapter.

       

      Just to be sure - it's the Glassfish who pulls the archive file or is it the Arquillian who pushes it?

       

      When I build the deployment archive, it is saved it /tmp/ARCHIVE_FILENAME (I'm running on GNU/Linux box) with chmod 444 (-r--r--r--). If I run the glassfish server as a root or as the same user as the maven than there is no problem. But actually I run a Jenkins build task (user: jenkins) and run the server as another user (user: pedro).

      In such case, the Arquillian remote tests fail because the Glassfish cannot use the /tmp/ARCHIVE_FILENAME (permission denied). If you change the chmod and give others the write permission - it will work fine.

       

      So, there is a workaround, but can you somehow say Arquillian what permissions the file should be created with?

       

      Thanks in advance,

      Cheers!