1 Reply Latest reply on Sep 2, 2011 10:59 PM by Mike Brock

    GWT 2.0.4 and Errai

    Andriy Rokhmanov Newbie

      Hi all,

       

      We have GWT 2.0.4 and looks like Errai is not compatible with this verison. For example, JSONUtilCli and JSONDecoder use JSONParser.parseStrict() method. The JSONParser does not have this method in GWT 2.0.4.

       

      What are your target GWT platforms, do you support older GWT versions?

       

      Thanks,

      Andriy

        • 1. Re: GWT 2.0.4 and Errai
          Mike Brock Master

          We have made a deicsion at this point to only support GWT 2.3+ in our latest release (1.3). The use of the parserStrict() method is part of an ongoing attempt to secure our code against security vulnerabilities such as cross-site scripting attacks. Another is our focus on HTML5. Thus, tracking new features within GWT 2.3 which provide us better support therein is a natural fit.

           

          As our project moves forward, we will make an effort to improve our compatibility profile with various GWT versions.