2 Replies Latest reply on Sep 2, 2011 3:08 PM by Alexey Kazakov

    How to switch JBoss Tool 3.3M2 to EL 2.2 validation

    gauthier Peel Newbie

      hi

      After creating a new "Dynamic Web Project" using JSF2 and giving my project the JSF facet with V2, and alos JSF capabilities,

      JBoss tools still validate my XHTML pages  as old JSF1.2 pages.

       

      For example, the validation detects an error on :

       

      <f:event type="preRenderView" listener="#{pilotAction.prepare(id)}" />

       

      the "(id)" is underlined. and the message  is : "Syntax error in EL"

       

      How to switch to EL 2.2 validation, i can't see any option in the "Preferences"  panel on Jboss Tool >  Web > Expression Language > Validation

       

      Could you show me how to set that right ?

       

      thanks