5 Replies Latest reply on Sep 13, 2011 10:19 AM by Tugcem Oral

    Module Deployment issue for JBoss 5.1

    Tugcem Oral Newbie

      Hi folks,

       

      We're using JBoss Tools 3.3 on Eclipse 3.7 (indigo) for a Seam(2.2.1) project with JBoss 5.1. Every installed plug-in and facets are compatible with each other that we didn't encounter with a problem up to now. We construct our project structure via Eclipse's Seam project wizard, so we have *-ear and *-ejb projects, too. However, when we decide to include Quartz Scheduler to our project, things start to get worse. We define quartz.jar as a module in application.xml and put required jar to corresponding classpath. And we defined in Project > Properies > Deployment Assembly that quartz.jar should be deployed to root of .ear project by JBoss AS. This deployment structure can also be seen in org.eclipse.wst.common.component configuration file. However, JBoss does not deploy quartz.jar to required path. It deploys any other file that we put on the directory of quartz.jar and also jboss-seam.jar, too. When we change quartz.jar name to any other name, it also deploys it. But now on other machine, we must rename it to make it deploy, so it continues infinitely.

       

      We think that this bug should be related with JBoss Tools, but could be Eclipse's WTP plugin bug, too.

       

      Have you ever encountered such a problem like this? I think this issue is unrelated with quartz or other module. If any required configuration file or info required, I'd love to share.

       

      Thanks in advance.