0 Replies Latest reply on Sep 14, 2011 3:07 PM by Brendan Healey

    h:commandButton inside popupPanel problem in 4.1.0.M1

    Brendan Healey Master

      Hi, I'm using the Tomahawk t:inputFileUpload component which won't work with Ajax, so as far as I

      presently understand I can't use a4j:commandButton and instead have to use h:commandButton. The

      code is structured like this:

       

      <rich:popupPanel domElementAttachment="form">

        <h:form enctype="multipart/form-data">

          <t:inputFileUpload .../>

          <h:commandButton action="..."/>

        </h:form>

      </rich:popupPanel>

       

      The popupPanel code is inside a ui:composition in a separate .xhtml file which is ui:include'd into

      another xhtml file. This code has worked for years inside a primefaces dialog, but with the switch to

      an RF popupPanel the action/actionListener methods no longer get executed. It's also worth noting

      that there are multiple forms within the view.

       

      I'm aware that people have experienced similar problems hence the addition of the domElementAttachment

      ="form", but this hasn't made any difference. I tried a4j:commandButton and as described elsewhere in this

      forum you seem to have to click the button twice before the action method(s) fire.

       

      So I just wondered if anyone had any suggestions for how to progress this? is it possible to get

      a4j:commandButton to send a non-ajax request? Alternatively perhaps I could just use a jquery dialog for

      the time being?

       

      Thanks for any help.

       

      Brendan.