3 Replies Latest reply on Sep 20, 2011 11:20 AM by Craig Greenhalgh

    Is Jboss 7 Supported?

    Craig Greenhalgh Newbie

      Hi I have tried to build a profile as per the achetype and run the jboss 7 profile

       

      It fails to package due to

       

      IllegalArgumentException: Illegal character in path at index 90: https://repository.jboss.org/nexus/content/groups/public/com/google/code/gwt-log/gwt-log/${gwt-log.version}/gwt-log-${gwt-log.version}.pom

       

      I have added a property gwt-log.version but this still doesn't fix the issue

       

      Any ideas?

       

      Many thanks

       

      Craig


        • 1. Re: Is Jboss 7 Supported?
          Craig Greenhalgh Newbie

          I now get the following when I deploy to AS7

           

          WeldService: org.jboss.weld.exceptions.DefinitionException: Exception List with 1 exceptions:

          Exception 0 :

          java.lang.RuntimeException: could not initialize ErraiService instance

              at org.jboss.errai.cdi.server.Util.lookupErraiService(Util.java:142)

              at org.jboss.errai.cdi.server.CDIExtensionPoints.afterBeanDiscovery(CDIExtensionPoints.java:264)

              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

              at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)

              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

              at java.lang.reflect.Method.invoke(Method.java:616)

              at org.jboss.weld.util.reflection.SecureReflections$13.work(SecureReflections.java:305)

           

          Any ideas?

           

          Thanks

          • 2. Re: Is Jboss 7 Supported?
            Christian Sadilek Master

            Yes all demos and apps created with our archetypes work on AS7 given you use the jboss7 profile. Did you use the CDI archetype? Which version are you using?

            • 3. Re: Is Jboss 7 Supported?
              Craig Greenhalgh Newbie

              I have a basic example working now using

               

              mvn archetype:generate \
              -DarchetypeGroupId=org.jboss.errai.archetypes \
              -DarchetypeArtifactId=cdi-quickstart \
              -DarchetypeVersion=1.3.0-SNAPSHOT \
              -DarchetypeRepository=https://repository.jboss.org/nexus/content/repositories/snapshots/

               

              I think my about issue is because of using a seam module, peristsence or cron look like they could be the culprits so far, do you have an example that uses these?

               

              Thanks again

               

              Craig