13 Replies Latest reply on Sep 23, 2013 5:52 AM by Nayyereh Fazileh

    JCR Browser?

    Sverker Abrahamsson Novice

      What tools exsists for browsing a Modeshape JCR repository? I've tried with a few, but got none to work. Most seams to be tied to Jackrabbit also.

       

      These are the ones I've tested:

       

      http://sourceforge.net/projects/jcrbrowser - Plugin to Eclipse. Doesn't work properly with Eclipse 3.7, didn't connect to modeshape repository neither via rmi nor webdav

       

      http://sourceforge.net/projects/jcrconnector/ - Stand alone app, couldn't get it to connect via rmi

       

      http://www.jcr-explorer.org/index.html - Just found this one, haven't tested it yet. Only JSR 170 support

       

      http://www.day.com/eclipse.html - Eclipse plugin, couldn't make it connect to modeshape.

       

      http://code.google.com/p/sptjcrmanager/ - Web based tool. Didn't get it to deploy properly on a JBoss AS 5.1.0.GA

       

      Neither have I've been able to connect the built in webdav client in Windows 7 to modeshape-webdav, I keep on getting "The folder you entered does not appear to be valid". The only tools I've been able to use has been directly in Interner Explorer and with cadaver.

       

      I would like to find a tool that can display all the JCR 2.0 nodes and attributes as it's a big help when developing to be able to see what is acctually in the repo, execute queries etc.

        • 1. Re: JCR Browser?
          Julien Viet Apprentice

          you can give a try to CRaSH an extensible shell that integrates with JCR, it does not support mounting of modeshape repositories but I think it would be trivial to integrate with. It's very useful for testing JCR queries or browsing a repository.

          • 2. Re: JCR Browser?
            Torsten Witte Newbie

            You can try Toromiro. It is a standalone Eclipse application for  browsing and editing Java Content Repositories. Since version 1.6.0 it has a ModeShape add-on which optionally can be installed from the Toromiro Extensions Update Site using Help > Install New Software...

            Check the documentation for further information. If you have any problems, find a bug or have feature requests feel free to create an issue here.

            • 3. Re: JCR Browser?
              K. Bachl Novice

              Hello Torsten,

               

              sounds interesting, it has to be noted however that Toromino is not free and not cheap. I tried it today but wasn't able to try it on modeshape as the install fails with:

               

              An error occurred while collecting items to be installed

                session context was:(profile=profile, phase=org.eclipse.equinox.internal.provisional.p2.engine.phases.Collect, operand=, action=).

                No repository found containing: osgi.bundle,com.subshell.toromiro.adapter.modeshape.2.6,1.6.0

                No repository found containing: osgi.bundle,com.subshell.toromiro.adapter.modeshape.2.7,1.6.0

                No repository found containing: org.eclipse.update.feature,com.subshell.toromiro.adapter.modeshape.feature,1.6.0

                No repository found containing: osgi.bundle,com.subshell.toromiro.adapter.modeshape.help,1.6.0

              • 4. Re: JCR Browser?
                Torsten Witte Newbie

                Hello K. Bachl,

                 

                seems that you have run into a known bug.

                You have to remove the last "/" from the Extensions Update Site URL and press "Test connection" in File > Preferences > Install/Update > Available Software Sites.

                See "(Automatic) Update does not work" in the "Trouble Shooting" section of our documentation.

                 

                Afterwards you should be able to install the ModeShape add-on.

                • 5. Re: JCR Browser?
                  K. Bachl Novice

                  Hello Torsten,

                   

                  did what you said and it then it works at first. But now I'm on next problem during install, see:

                   

                  An error occurred while installing the items

                    session context was:(profile=profile, phase=org.eclipse.equinox.internal.provisional.p2.engine.phases.Install, operand=null --> [R]com.subshell.toromiro.adapter.modeshape.2.6 1.6.0, action=org.eclipse.equinox.internal.p2.touchpoint.eclipse.actions.InstallBundleAction).

                    Error while loading manipulator.

                    Error while loading manipulator.

                   

                  I'm on OS X Lion; At least I now know again why I never liked eclipse

                  • 6. Re: JCR Browser?
                    Torsten Witte Newbie

                    Hello K. Bachl,

                     

                    please add the following lines in the top of Toromiro/Toromiro.app/Contents/MacOS/toromiro.ini (example for 64 bit version) and try again to install the add-on:

                     

                    -startup

                    ../../../plugins/org.eclipse.equinox.launcher_1.0.201.R35x_v20090715.jar

                    --launcher.library

                    ../../../plugins/org.eclipse.equinox.launcher.cocoa.macosx.x86_64_1.0.1.R35x_v20090707

                    • 7. Re: JCR Browser?
                      Torsten Witte Newbie

                      Okay, here the complete workaround for all Mac users who want to try Toromiro 1.6.0 with ModeShape add-on (testet on Mac OS X 10.7.3 64bit)

                       

                      1. Download Toromiro from official download page (e.g. Toromiro-1.6.0-macosx.cocoa.x86_64.zip).

                      2. Extract the zip file into a folder of your choice.

                      3. Edit Toromiro/Toromiro.app/Contents/MacOS/toromiro.ini and add the following lines at the beginning of the file (example is for Cocoa 64bit, look here for other Mac versions):

                       

                      -startup

                      ../../../plugins/org.eclipse.equinox.launcher_1.0.201.R35x_v20090715.jar

                      --launcher.library

                      ../../../plugins/org.eclipse.equinox.launcher.cocoa.macosx.x86_64_1.0.1.R35x_v20090707

                       

                      4. Start Toromiro for the first time and enter your licence key.

                      5. Go to File > Preferences > Install/Update > Available Software Sites and remove the last slash ("/") from each update site URL and press the Test Connection button like described here.

                      6. Install the ModeShape add-on from Toromiro Extensions Update Site using Help > Install New Software...

                      7. Restart Toromiro

                       

                      We are working on a fix for that problem and will create a bugfix release in the next time.

                      • 8. Re: JCR Browser?
                        Randall Hauch Master

                        Thanks, Torsten, for providing this recipe. Very cool.

                        • 9. Re: JCR Browser?
                          Torsten Witte Newbie

                          I've just copied the Toromiro 1.6.1 bugfix release to our download/update servers. The problems described above will not appear with that version.

                           

                          Thanks to K. Bachl for reporting the bug.

                          • 10. Re: JCR Browser?
                            Randall Hauch Master

                            Thanks, Torsten, for fixing Toromino to accommodate this. Great work.

                            • 11. Re: JCR Browser?
                              Nayyereh Fazileh Newbie

                              Hi, I'm working modeshape and I want this tool too. something like a browser to see Modeshape JCR repository.
                              Do you get your correct answer?

                              I will appreciate if any body help me!

                              Thank you.

                              • 12. Re: JCR Browser?
                                Horia Chiorean Master

                                We already have an "early access" pull request for it: https://github.com/ModeShape/modeshape/pull/919

                                It's not merged yet, but we hope to include it soon.

                                1 of 1 people found this helpful
                                • 13. Re: JCR Browser?
                                  Nayyereh Fazileh Newbie

                                  Thank you for response. And thank the team.