1 Reply Latest reply on Sep 28, 2011 5:09 PM by Jeff Kouba

    cannot edit anything in codehoop eclipse bpmn plugin

    Jeff Kouba Newbie

      I am very new to jbpmn, and have been playing around with it, trying to evaluate how we might use it in a project. I am using Eclipse Indigo SR 1.

       

      I've installed JBPM 5.1, and the Eclipse BPMN plugin from codehoop. (I installed graphiti and the eclipse modeling framework as well.)

       

      The thing is, I don't seem to be able to edit anything in a process. I've created a very basic Hello World process, with start and end points, and a script task. The process will run.

       

      When I double click on any of those, however, I don't get any kind of editor. I assume there must be some way of editing the various artifacts?

       

      Do I still need to install something? Am I missing something? I can edit the xml directly, and I dropped in a println statement in the script task, and change the process name, and so forth, but manually editing xml rather defeats the purpose of having a visual editor.

       

      thanks...

        • 1. Re: cannot edit anything in codehoop eclipse bpmn plugin
          Jeff Kouba Newbie

          I might add, I installed the jbpm-5.1.0.Final-installer-full.zip, and ran the "ant install.demo" and accessed the sample evaluation project that comes with that.

           

          When I run the eclipse that comes with this demo (helios) I am able to edit the sample process that comes with that project. I can click on the human tasks and I get a little popup editor. The visual editor that comes with that is whatever comes with the plugin, it's not the codehoop plugin.

           

          I've tried to go through the plugins that are in this canned instance of helios, and what I have in my Indigo install, but it's not immediately obvious to me that there are differences that would cause this issue.