1 Reply Latest reply on Sep 28, 2011 2:23 PM by msuscorpio

    Unable to get to JBoss EAP 4.3 Web Console

    msuscorpio Newbie

      Hello, let me preface this by saying I am a complete noob to the world of Jboss and obviously this community.  So, please excuse me if I have posted this in the wrong section.  I am not a noob to the world of application servers as I have experience with IBM Websphere. 

       

      I have been given the task of configuring a Jboss EAP 4.3 server running on Red Hat Enterprise Linux 5 that will ultimately serve an HP SOA application.  EAP 4.3 was installed by someone else a few months ago and, far as I can tell, the default configuration has been left as is.  I cant seem to get the web console to come up.  I have tried using the dns name (http://myserver.mydomain.com:8080, http://myserver.mydomain.com:8443) as well as https.  Ive also tried both ports, secured and standard using the server IP. all I seem to get is the standard "Internet Explorer cannot display the webpage" error.  I have restarted the service many times using the default shutdown.sh and run.sh scripts, but that doesnt seem to help.   One thing that is puzzling is when I run a netstat, neither 8080 or 8443 show up in the list of active open ports.

       

      I did some digging into the logs.  the boot.log and init log look fine.  The server.log

      file does have this entry in it over and over.

       

      WARN  [com.arjuna.ats.jta.logging.loggerI18N] [com.arjuna.ats.internal.jta.recovery.xarecovery1] Local XARecoveryModule.xaRecovery  got XA exception javax.transaction.xa.XAException: Error trying to connect to provider java:/DefaultJMSProvider, XAException.XAER_RMERR

       

       

      First, I would like to know what is the proper way to start and stop the server.  Shuold I use sh run.sh -b (ip address) as I have seen in some of my google searches?  Then, I could use some help trouble shooting my console issues. I can provide any additional information you may need.  IThank you in advance for your time!