0 Replies Latest reply on Oct 8, 2011 10:48 AM by Jack Terranova

    Hotdeploy classloader connection issue

    Jack Terranova Newbie

      I was experiencing what appeared to be a class loader issue when hot deploying an unexploded war file in jboss-4.2.2.GA.

       

      Once hot deployed the application appeared responsive, but failed with any database activity.  Unfortunately I do not have an exact stack trace as I can not longer reproduce the issue. 

       

      The exception was occuring in the Oracle ojdbc14.jar getConnection method.  There were stack traces all over, including excpetions around tx resource registration, class loading (appeared related to ojdbc14.jar) and NPEs (for the actual connection).

       

      I had noticed ojdbc14.jar was in my war file.  I removed it and tried re-hotdeployoing and it seemed to solve the issue.  When I tried the same on my dev server, the problem persisted.  I was deploying in a couple of ways - through jboss-maven-plugin (hard and soft deploy) as well as an old fashioned war copy into the deploy dir.  Same issue either way.

       

      Now all of a sudden I cannot reproduce the issue locally or in my dev server.  Maybe the soft deploys I was doing was leaving the old war file in the deploy dir - the war that still contained ojdbc14.jar and was somehow being reloaded? 

       

      I am surprised that I cannot find a lot of resources on this issue - I would have thought it quite common.

       

      When hot deploys fail like this where is the best place to start looking for the issue?  Is it generally a class loading problem?

       

      Thanks for any help.