2 Replies Latest reply on Oct 18, 2011 5:27 AM by Hans Wolffenbuttel

    HttpGateway sync/async

    swienty1 Newbie

      Hi,

       

      I have problem with configuration HttpGateway. I would like give answer for http request and send jms message in the same service. So my situation:

       

      Client sent information to HttpGateway, this gateway process some actions (in RequestResponse mode), give response to client (not statuscode, but some information generated by actions). I would like also after send information to client start other service (this new service should work in async/oneWay mode)

       

       

      client->

      --------->actions in first service

                ----->call next service (next service will work in async mode)

      <--------response from first service to client

                end of first service

       

       

                       second service still work and do something

       

      I try with such configuration:

       

       

      <?xml version="1.0"?>
      <jbossesb parameterReloadSecs="5"
       xmlns="http://anonsvn.labs.jboss.com/labs/jbossesb/trunk/product/etc/schemas/xml/jbossesb-1.3.0.xsd"
       xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://anonsvn.labs.jboss.com/labs/jbossesb/trunk/product/etc/schemas/xml/jbossesb-1.3.0.xsd http://anonsvn.jboss.org/repos/labs/labs/jbossesb/trunk/product/etc/schemas/xml/jbossesb-1.3.0.xsd">
       <providers>
        <http-provider name="wejscie">
         <http-bus busid="wejscie"/>
        </http-provider>
       </providers>
       <services>
        <service category="nauka" description="nauka" invmScope="GLOBAL" name="nauka">
         <listeners>
          <http-gateway busidref="wejscie" name="wejscie" payloadAs="STRING" urlPattern="maciej/*">
          </http-gateway> 
         </listeners>
         <actions mep="RequestResponse">
          <action class="test.MyAction" name="myaction" process="displayMessage"/>
          <action class="org.jboss.soa.esb.actions.routing.JMSRouter" name="routeToReplyQueue">
           <property name="jndiName" value="queue/quickstart_jms_router_Request_gw"/>
           <property name="connection-factory" value="ConnectionFactory"/>
           <property name="unwrap" value="true"/>
          </action>
          <action class="test.MyAction3" name="myaction3" process="displayMessage"/>
         </actions>
        </service>
       </services>
      </jbossesb>
      

       

      But JMSRouter stop processing actions and I get "No response message for RequestResponse mep!" because myaction3 will not start.

       

      I don't know how to configure JbossESB to work in such way. Thank for any help.