0 Replies Latest reply on Oct 13, 2011 1:17 AM by suresh kumar

    Failed to Create new SAX Parser Exception in jboss 5.1.0

    suresh kumar Newbie

      Hi all,      

      We are getting the below exception after changing the tag structuring order in jboss-app.xml im META-INF directory packaged in my EAR file under server\default\deploy folder.In our application,we use struts framework and hibernate and got othing to do with EJB.We are not able to figure out the reason behind it and will also post the contents of my jboss-app.xml over here.This is occuring while migrating our application from jboss 3.2.7 to jboss 5.1.0.We use the jboss-5.1.0 compiled with jdk 1.6 version.We have already tried removing the xerces jars,xml-apis jars etc but it did not help.Any information would be really helpful.

        Deployment "jboss.web.deployment:war=/ROOT" is missing the following dependencies:

          Dependency "jboss.web:service=WebServer" (should be in state "Create", but is actually in state

      "** NOT FOUND Depends on 'jboss.web:service=WebServer' **")

        Deployment "jboss.web.deployment:war=/admin-console" is missing the following dependencies:

          Dependency "jboss.web:service=WebServer" (should be in state "Create", but is actually in state

      "** NOT FOUND Depends on 'jboss.web:service=WebServer' **")

        Deployment "jboss.web.deployment:war=/axis2" is missing the following dependencies:

          Dependency "jboss.web:service=WebServer" (should be in state "Create", but is actually in state

      "** NOT FOUND Depends on 'jboss.web:service=WebServer' **")

        Deployment "jboss.web.deployment:war=/ems" is missing the following dependencies:

          Dependency "jboss.web:service=WebServer" (should be in state "Create", but is actually in state

      "** NOT FOUND Depends on 'jboss.web:service=WebServer' **")

        Deployment "jboss.web.deployment:war=/invoker" is missing the following dependencies:

          Dependency "jboss.web:service=WebServer" (should be in state "Create", but is actually in state

      "** NOT FOUND Depends on 'jboss.web:service=WebServer' **")

        Deployment "jboss.web.deployment:war=/jbossws" is missing the following dependencies:

          Dependency "jboss.web:service=WebServer" (should be in state "Create", but is actually in state

      "** NOT FOUND Depends on 'jboss.web:service=WebServer' **")

        Deployment "jboss.web.deployment:war=/jmx-console" is missing the following dependencies:

          Dependency "jboss.web:service=WebServer" (should be in state "Create", but is actually in state

      "** NOT FOUND Depends on 'jboss.web:service=WebServer' **")

        Deployment "jboss.web.deployment:war=/portal" is missing the following dependencies:

          Dependency "jboss.web:service=WebServer" (should be in state "Create", but is actually in state

      "** NOT FOUND Depends on 'jboss.web:service=WebServer' **")

        Deployment "jboss.web.deployment:war=/web-console" is missing the following dependencies:

          Dependency "jboss.web:service=WebServer" (should be in state "Create", but is actually in state

      "** NOT FOUND Depends on 'jboss.web:service=WebServer' **")

       

      Deployment "WebServer" is in error due to the following reason(s): javax.xml.parsers.ParserConfigu

      rationException: Feature 'http://apache.org/xml/features/xinclude' is not recognized.

        Deployment "jboss.web:service=WebServer" is in error due to the following reason(s): ** NOT FOUND

      Depends on 'jboss.web:service=WebServer' **

       

      Contents of jboss-app.xml before the change:

      <!DOCTYPE jboss-app
      PUBLIC "-//JBoss//DTD Java EE Application 5.0//EN"
      "http://www.jboss.org/j2ee/dtd/jboss-app_5_0.dtd">


      <jboss-app>   
        <module> 
          <service>ems.sar</service>
        </module>
        <module> 
          <service>axis2.war</service>
        </module>
        <module> 
          <service>ems.war</service>
        </module>
      </jboss-app>

       

      Contents of jboss-app.xml after the change:

      <!DOCTYPE jboss-app
      PUBLIC "-//JBoss//DTD Java EE Application 5.0//EN"
      "http://www.jboss.org/j2ee/dtd/jboss-app_5_0.dtd">


      <jboss-app>   
        <module>
                  <web>
                      <web-uri>ems.war</web-uri>
                      <context-root>/ems</context-root>
                  </web>
          </module>
        <module> 
            <service>ems.sar</service>
        </module>
        <module> 
        <web>
                          <web-uri>axis2.war</web-uri>
                    <context-root>/axis2</context-root>
                  </web>
        </module>
      </jboss-app>

       

      The contents of jboss-app.xml was done to resolve the classcast exception that we were getting before.Refer this thread below for more details.

      http://community.jboss.org/thread/173226

       

       

      Thanks,

      Sureshkumar