2 Replies Latest reply on Oct 15, 2011 2:10 PM by Hauke Gulich

    Problems connecting to JMS

    Hauke Gulich Newbie

      Hello everyone,

       

      I just wanted to do the example application from the hornetQ Documentation without luck.

       

      I am using JBoss 7.0.2 and set up everything (hopefully correct). If I go to the administration console I see the following:

       

       

       

      jms001.PNG

       

       

       

       

       

      So my three queues are set up.

       

      Now I did this simple application and try to run this OUTSIDE from JBoss but still on the same machine.

       

       

       

       

       

       

       

      {code}

      package testing;

       

      import javax.jms.Connection;

      import javax.jms.ConnectionFactory;

      import javax.jms.JMSException;

      import javax.jms.MessageConsumer;

      import javax.jms.MessageProducer;

      import javax.jms.Queue;

      import javax.jms.Session;

      import javax.jms.TextMessage;

      import javax.naming.InitialContext;

      import javax.naming.NamingException;

       

      public class Testing {

       

          /**

           * @param args

           */

          public static void main(String[] args) {

       

              InitialContext ic;

              try {

                  ic = new InitialContext();

       

                  ConnectionFactory cf = (ConnectionFactory) ic.lookup("java:/ConnectionFactory");

       

                  Queue orderQueue = (Queue) ic.lookup("/queue/toServer");

       

                  Connection connection = cf.createConnection();

       

                  Session session = connection.createSession(false,Session.AUTO_ACKNOWLEDGE);

       

                  MessageProducer producer = session.createProducer(orderQueue);

       

                  MessageConsumer consumer = session.createConsumer(orderQueue);

       

                  connection.start();

       

                  TextMessage message = session.createTextMessage("This is an order");

                  producer.send(message);

       

                  TextMessage receivedMessage = (TextMessage) consumer.receive();

                  System.out.println("Got order: " + receivedMessage.getText());

                 

              } catch (NamingException e) {

                  // TODO Auto-generated catch block

                  e.printStackTrace();

              } catch (JMSException e) {

                  // TODO Auto-generated catch block

                  e.printStackTrace();

              }

       

          }

       

      }

      {code}

       

       

      and I created a jndi.properties file in the resource folder with this content

       

       

      java.naming.factory.initial=org.jnp.interfaces.NamingContextFactory

      java.naming.provider.url=jnp://127.0.0.1:1099

      java.naming.factory.url.pkgs=org.jboss.naming:org.jnp.interfaces

       

       

       

       

      But I always get errors like this

       

       

       

       

       

      {color:#f00}

      javax.naming.CommunicationException: Could not obtain connection to any of these urls: localhost and discovery failed with error: javax.naming.CommunicationException: Receive timed out [Root exception is java.net.SocketTimeoutException: Receive timed out] [Root exception is javax.naming.CommunicationException: Failed to connect to server localhost:1099 [Root exception is javax.naming.ServiceUnavailableException: Failed to connect to server localhost:1099 [Root exception is java.net.ConnectException: Connection refused: connect]]]

          at org.jnp.interfaces.NamingContext.checkRef(NamingContext.java:1562)

          at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:634)

          at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:627)

          at javax.naming.InitialContext.lookup(Unknown Source)

          at testing.Testing.main(Testing.java:25)

      Caused by: javax.naming.CommunicationException: Failed to connect to server localhost:1099 [Root exception is javax.naming.ServiceUnavailableException: Failed to connect to server localhost:1099 [Root exception is java.net.ConnectException: Connection refused: connect]]

          at org.jnp.interfaces.NamingContext.getServer(NamingContext.java:274)

          at org.jnp.interfaces.NamingContext.checkRef(NamingContext.java:1533)

          ... 4 more

      Caused by: javax.naming.ServiceUnavailableException: Failed to connect to server localhost:1099 [Root exception is java.net.ConnectException: Connection refused: connect]

          at org.jnp.interfaces.NamingContext.getServer(NamingContext.java:248)

          ... 5 more

      Caused by: java.net.ConnectException: Connection refused: connect

          at java.net.PlainSocketImpl.socketConnect(Native Method)

          at java.net.PlainSocketImpl.doConnect(Unknown Source)

          at java.net.PlainSocketImpl.connectToAddress(Unknown Source)

          at java.net.PlainSocketImpl.connect(Unknown Source)

          at java.net.SocksSocketImpl.connect(Unknown Source)

          at java.net.Socket.connect(Unknown Source)

          at java.net.Socket.connect(Unknown Source)

          at java.net.Socket.<init>(Unknown Source)

          at java.net.Socket.<init>(Unknown Source)

          at org.jnp.interfaces.TimedSocketFactory.createSocket(TimedSocketFactory.java:84)

          at org.jnp.interfaces.TimedSocketFactory.createSocket(TimedSocketFactory.java:77)

          at org.jnp.interfaces.NamingContext.getServer(NamingContext.java:244)

          ... 5 more

      {color}

       

       

       

       

      So I tried to use the telnet command from the console (windows console) on port 1099 without luck and "netstat -a" doesn't show port 1099 as well on localhost.

       

       

      So I checked if the jndi service is set up on jboss (I use the default configuration from jboss) and on this screen it looks correct

       

       

       

      jms002.PNG

       

       

       

      In case somebody needs my standalone.xml file

       

       

      {code:xml}

      <?xml version='1.0' encoding='UTF-8'?>

       

      <server name="Gulich-PC" xmlns="urn:jboss:domain:1.0">

          <extensions>

              <extension module="org.jboss.as.clustering.infinispan"/>

              <extension module="org.jboss.as.connector"/>

              <extension module="org.jboss.as.deployment-scanner"/>

              <extension module="org.jboss.as.ee"/>

              <extension module="org.jboss.as.ejb3"/>

              <extension module="org.jboss.as.jaxrs"/>

              <extension module="org.jboss.as.jmx"/>

              <extension module="org.jboss.as.jpa"/>

              <extension module="org.jboss.as.logging"/>

              <extension module="org.jboss.as.messaging"/>

              <extension module="org.jboss.as.naming"/>

              <extension module="org.jboss.as.osgi"/>

              <extension module="org.jboss.as.pojo"/>

              <extension module="org.jboss.as.remoting"/>

              <extension module="org.jboss.as.sar"/>

              <extension module="org.jboss.as.security"/>

              <extension module="org.jboss.as.threads"/>

              <extension module="org.jboss.as.transactions"/>

              <extension module="org.jboss.as.web"/>

              <extension module="org.jboss.as.weld"/>

          </extensions>

          <management>

              <security-realms>

                  <security-realm name="PropertiesMgmtSecurityRealm">

                      <authentication>

                          <properties path="mgmt-users.properties" relative-to="jboss.server.config.dir"/>

                      </authentication>

                  </security-realm>

              </security-realms>

              <management-interfaces>

                  <native-interface interface="management" port="9999"/>

                  <http-interface interface="management" port="9990"/>

              </management-interfaces>

          </management>

          <profile>

              <subsystem xmlns="urn:jboss:domain:logging:1.1">

                  <console-handler name="CONSOLE" autoflush="true">

                      <level name="INFO"/>

                      <formatter>

                          <pattern-formatter pattern="%d{HH:mm:ss,SSS} %-5p [%c] (%t) %s%E%n"/>

                      </formatter>

                  </console-handler>

                  <periodic-rotating-file-handler name="FILE" autoflush="true">

                      <level name="INFO"/>

                      <formatter>

                          <pattern-formatter pattern="%d{HH:mm:ss,SSS} %-5p [%c] (%t) %s%E%n"/>

                      </formatter>

                      <file relative-to="jboss.server.log.dir" path="server.log"/>

                      <suffix value=".yyyy-MM-dd"/>

                      <append value="true"/>

                  </periodic-rotating-file-handler>

                  <logger category="com.arjuna">

                      <level name="WARN"/>

                  </logger>

                  <logger category="org.apache.tomcat.util.modeler">

                      <level name="WARN"/>

                  </logger>

                  <logger category="sun.rmi">

                      <level name="WARN"/>

                  </logger>

                  <root-logger>

                      <level name="INFO"/>

                      <handlers>

                          <handler name="CONSOLE"/>

                          <handler name="FILE"/>

                      </handlers>

                  </root-logger>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:datasources:1.0">

                  <datasources>

                      <datasource jndi-name="java:jboss/datasources/ExampleDS" pool-name="H2DS" enabled="true" jta="true" use-java-context="true" use-ccm="true">

                          <connection-url>

                              jdbc:h2:mem:test;DB_CLOSE_DELAY=-1

                          </connection-url>

                          <driver>

                              h2

                          </driver>

                          <pool>

                              <prefill>

                                  false

                              </prefill>

                              <use-strict-min>

                                  false

                              </use-strict-min>

                              <flush-strategy>

                                  FailingConnectionOnly

                              </flush-strategy>

                          </pool>

                          <security>

                              <user-name>

                                  sa

                              </user-name>

                              <password>

                                  sa

                              </password>

                          </security>

                      </datasource>

                      <datasource jndi-name="SCHWIMMBAD_DS" pool-name="SCHWIMMBAD_DS_Pool" enabled="true" jta="true" use-java-context="true" use-ccm="true">

                          <connection-url>

                              jdbc:mysql://localhost/schwimmbad

                          </connection-url>

                          <driver>

                              mysql-connector-java-5.1.17.jar

                          </driver>

                          <security>

                              <user-name>

                                  *******

                              </user-name>

                              <password>

                                  ********

                              </password>

                          </security>

                      </datasource>

                      <drivers>

                          <driver name="h2" module="com.h2database.h2">

                              <xa-datasource-class>

                                  org.h2.jdbcx.JdbcDataSource

                              </xa-datasource-class>

                          </driver>

                      </drivers>

                  </datasources>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:deployment-scanner:1.0">

                  <deployment-scanner name="default" path="deployments" scan-enabled="true" scan-interval="5000" relative-to="jboss.server.base.dir" deployment-timeout="60"/>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:ee:1.0"/>

              <subsystem xmlns="urn:jboss:domain:ejb3:1.1" lite="true">

                  <session-bean>

                      <stateless>

                          <bean-instance-pool-ref pool-name="slsb-strict-max-pool"/>

                      </stateless>

                  </session-bean>

                  <pools>

                      <bean-instance-pools>

                          <strict-max-pool name="slsb-strict-max-pool" max-pool-size="20" instance-acquisition-timeout="5" instance-acquisition-timeout-unit="MINUTES"/>

                      </bean-instance-pools>

                  </pools>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:infinispan:1.0" default-cache-container="hibernate">

                  <cache-container name="hibernate" default-cache="local-query">

                      <local-cache name="entity">

                          <eviction strategy="LRU" max-entries="10000"/>

                          <expiration max-idle="100000"/>

                      </local-cache>

                      <local-cache name="local-query">

                          <eviction strategy="LRU" max-entries="10000"/>

                          <expiration max-idle="100000"/>

                      </local-cache>

                      <local-cache name="timestamps">

                          <eviction strategy="NONE"/>

                      </local-cache>

                  </cache-container>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:jaxrs:1.0"/>

              <subsystem xmlns="urn:jboss:domain:jca:1.0">

                  <archive-validation enabled="false"/>

                  <bean-validation enabled="false"/>

                  <default-workmanager>

                      <short-running-threads blocking="true" allow-core-timeout="false">

                          <core-threads count="10" per-cpu="20"/>

                          <queue-length count="10" per-cpu="20"/>

                          <max-threads count="10" per-cpu="20"/>

                          <keepalive-time time="10" unit="SECONDS"/>

                      </short-running-threads>

                      <long-running-threads blocking="true" allow-core-timeout="false">

                          <core-threads count="10" per-cpu="20"/>

                          <queue-length count="10" per-cpu="20"/>

                          <max-threads count="10" per-cpu="20"/>

                          <keepalive-time time="10" unit="SECONDS"/>

                      </long-running-threads>

                  </default-workmanager>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:jmx:1.0">

                  <jmx-connector server-binding="jmx-connector-server" registry-binding="jmx-connector-registry"/>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:jpa:1.0">

                  <jpa default-datasource=""/>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:messaging:1.0">

                  <persistence-enabled>

                      false

                  </persistence-enabled>

                  <journal-type>

                      NIO

                  </journal-type>

                  <journal-file-size>

                      102400

                  </journal-file-size>

                  <acceptors>

                      <netty-acceptor name="netty" socket-binding="messaging"/>

                      <netty-acceptor name="netty-throughput" socket-binding="messaging-throughput">

                          <param key="batch-delay" value="50"/>

                          <param key="direct-deliver" value="false"/>

                      </netty-acceptor>

                      <in-vm-acceptor name="in-vm" server-id="0"/>

                  </acceptors>

                  <address-settings>

                      <address-setting match="#">

                          <dead-letter-address>

                              jms.queue.DLQ

                          </dead-letter-address>

                          <expiry-address>

                              jms.queue.ExpiryQueue

                          </expiry-address>

                          <redelivery-delay>

                              0

                          </redelivery-delay>

                          <max-size-bytes>

                              10485760

                          </max-size-bytes>

                          <message-counter-history-day-limit>

                              10

                          </message-counter-history-day-limit>

                          <address-full-policy>

                              BLOCK

                          </address-full-policy>

                      </address-setting>

                  </address-settings>

                  <connectors>

                      <netty-connector name="netty" socket-binding="messaging"/>

                      <netty-connector name="netty-throughput" socket-binding="messaging-throughput">

                          <param key="batch-delay" value="50"/>

                      </netty-connector>

                      <in-vm-connector name="in-vm" server-id="0"/>

                  </connectors>

                  <security-settings>

                      <security-setting match="#">

                          <permission type="send" roles="guest"/>

                          <permission type="consume" roles="guest"/>

                          <permission type="createNonDurableQueue" roles="guest"/>

                          <permission type="deleteNonDurableQueue" roles="guest"/>

                      </security-setting>

                  </security-settings>

                  <jms-connection-factories>

                      <connection-factory name="InVmConnectionFactory">

                          <connectors>

                              <connector-ref connector-name="in-vm"/>

                          </connectors>

                          <entries>

                              <entry name="java:/ConnectionFactory"/>

                          </entries>

                      </connection-factory>

                      <connection-factory name="RemoteConnectionFactory">

                          <connectors>

                              <connector-ref connector-name="netty"/>

                          </connectors>

                          <entries>

                              <entry name="RemoteConnectionFactory"/>

                          </entries>

                      </connection-factory>

                      <pooled-connection-factory name="hornetq-ra">

                          <connectors>

                              <connector-ref connector-name="in-vm"/>

                          </connectors>

                          <entries>

                              <entry name="java:/JmsXA"/>

                          </entries>

                          <transaction mode="xa"/>

                      </pooled-connection-factory>

                  </jms-connection-factories>

                  <jms-destinations>

                      <jms-queue name="testQueue">

                          <entry name="queue/test"/>

                      </jms-queue>

                      <jms-queue name="queue/toServer">

                          <entry name="queue/toServer"/>

                      </jms-queue>

                      <jms-queue name="queue/toClient">

                          <entry name="queue/toClient"/>

                      </jms-queue>

                      <jms-queue name="queue/toHomematic">

                          <entry name="queue/toHomematic"/>

                      </jms-queue>

                      <jms-topic name="testTopic">

                          <entry name="topic/test"/>

                      </jms-topic>

                  </jms-destinations>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:naming:1.0"/>

              <subsystem xmlns="urn:jboss:domain:pojo:1.0"/>

              <subsystem xmlns="urn:jboss:domain:osgi:1.0" activation="lazy">

                  <configuration pid="org.apache.felix.webconsole.internal.servlet.OsgiManager">

                      <property name="manager.root">

                          jboss-osgi

                      </property>

                  </configuration>

                  <properties>

                      <property name="org.jboss.osgi.system.modules">

                          org.apache.commons.logging,

                                                                                                                                                                                                                                                                                                              org.apache.log4j,

                                                                                                                                                                                                                                                                                                              org.jboss.as.osgi,

                                                                                                                                                                                                                                                                                                              org.slf4j,

                      </property>

                      <property name="org.osgi.framework.startlevel.beginning">

                          1

                      </property>

                      <property name="org.osgi.framework.system.packages.extra">

                          org.apache.commons.logging;version=1.1.1,

                                                                                                                                                                                                                                                                                                              org.apache.log4j;version=1.2,

                                                                                                                                                                                                                                                                                                              org.jboss.as.osgi.service;version=7.0,

                                                                                                                                                                                                                                                                                                              org.jboss.osgi.deployment.interceptor;version=1.0,

                                                                                                                                                                                                                                                                                                              org.jboss.osgi.spi.capability;version=1.0,

                                                                                                                                                                                                                                                                                                              org.jboss.osgi.spi.util;version=1.0,

                                                                                                                                                                                                                                                                                                              org.jboss.osgi.testing;version=1.0,

                                                                                                                                                                                                                                                                                                              org.jboss.osgi.vfs;version=1.0,

                                                                                                                                                                                                                                                                                                              org.slf4j;version=1.5.10,

                      </property>

                  </properties>

                  <modules>

                      <module identifier="javaee.api"/>

                      <module identifier="org.jboss.logging"/>

                      <module identifier="org.apache.aries.util"/>

                      <module identifier="org.jboss.osgi.webconsole"/>

                      <module identifier="org.osgi.compendium"/>

                      <module identifier="org.apache.felix.log" startlevel="1"/>

                      <module identifier="org.jboss.osgi.logging" startlevel="1"/>

                      <module identifier="org.apache.felix.configadmin" startlevel="1"/>

                      <module identifier="org.jboss.as.osgi.configadmin" startlevel="1"/>

                      <module identifier="org.apache.aries.jmx" startlevel="2"/>

                      <module identifier="org.apache.felix.eventadmin" startlevel="2"/>

                      <module identifier="org.apache.felix.metatype" startlevel="2"/>

                      <module identifier="org.apache.felix.scr" startlevel="2"/>

                      <module identifier="org.apache.felix.webconsole" startlevel="2"/>

                      <module identifier="org.jboss.osgi.jmx" startlevel="2"/>

                      <module identifier="org.jboss.osgi.http" startlevel="2"/>

                      <module identifier="org.jboss.osgi.blueprint" startlevel="3"/>

                      <module identifier="org.jboss.osgi.webapp" startlevel="3"/>

                      <module identifier="org.jboss.osgi.xerces" startlevel="3"/>

                  </modules>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:remoting:1.0"/>

              <subsystem xmlns="urn:jboss:domain:resource-adapters:1.0"/>

              <subsystem xmlns="urn:jboss:domain:sar:1.0"/>

              <subsystem xmlns="urn:jboss:domain:security:1.0">

                  <security-domains>

                      <security-domain name="other" cache-type="default">

                          <authentication>

                              <login-module code="Disabled" flag="required"/>

                          </authentication>

                      </security-domain>

                  </security-domains>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:threads:1.0"/>

              <subsystem xmlns="urn:jboss:domain:transactions:1.0">

                  <core-environment>

                      <process-id>

                          <uuid/>

                      </process-id>

                  </core-environment>

                  <recovery-environment socket-binding="txn-recovery-environment" status-socket-binding="txn-status-manager"/>

                  <coordinator-environment default-timeout="300"/>

                  <object-store/>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:web:1.0" default-virtual-server="default-host">

                  <connector name="http" protocol="HTTP/1.1" socket-binding="http" scheme="http"/>

                  <virtual-server name="default-host" enable-welcome-root="true">

                      <alias name="localhost"/>

                      <alias name="example.com"/>

                  </virtual-server>

              </subsystem>

              <subsystem xmlns="urn:jboss:domain:weld:1.0"/>

          </profile>

          <interfaces>

              <interface name="management">

                  <inet-address value="${jboss.bind.address.management:127.0.0.1}"/>

              </interface>

              <interface name="public">

                  <inet-address value="${jboss.bind.address:127.0.0.1}"/>

              </interface>

          </interfaces>

          <socket-binding-group name="standard-sockets" default-interface="public">

              <socket-binding name="http" port="8080"/>

              <socket-binding name="https" port="8443"/>

              <socket-binding name="jmx-connector-registry" port="1090" interface="management"/>

              <socket-binding name="jmx-connector-server" port="1091" interface="management"/>

              <socket-binding name="jndi" port="1099"/>

              <socket-binding name="osgi-http" port="8090" interface="management"/>

              <socket-binding name="remoting" port="4447"/>

              <socket-binding name="txn-recovery-environment" port="4712"/>

              <socket-binding name="txn-status-manager" port="4713"/>

              <socket-binding name="messaging" port="5445"/>

              <socket-binding name="messaging-throughput" port="5455"/>

          </socket-binding-group>

          <deployments>

              <deployment name="mysql-connector-java-5.1.17.jar" runtime-name="mysql-connector-java-5.1.17.jar">

                  <content sha1="60d52df83d1cc6bcfcb4bf7da3d5b3b912e82d8b"/>

              </deployment>

          </deployments>

      </server>

      {code}

       

       

       

      The other strange thing is, that I also implemented an JMS Service inside my web application and there it seems to work. The web application should put something inside a queue and the external java application should connect to the queue and should process the request from the web application.

      I don't get any errors on putting the message into the queue, but on the administration console there is a button "recent messages". If I click there, "no recent messages" will be displayed. I am not even sure if the JMS client inside the deployed application is working properly.

       

      Does anyone can give me a hint?

       

      Best regards

      Hauke