1 Reply Latest reply on Oct 19, 2011 8:47 AM by Maciej Swiderski

    JBPM console not displaying processes from my package

    Kiran A Newbie

      I created a new process in my package with guvnor/designer and built the package. This is the trace from the console

       

       

      12:38:42,322 INFO  [STDOUT] INFO  18-10 12:38:42,321 (LoggingHelper.java:info:50) Following assets have been included in package build: drools, testProcess,

       

       

      I modified the build.xml to run against Oracle10g and changed the  JNDI name.

       

      When I go to the jbpm-console and refresh the processview, the processes do not show up.

       

      I also see this on the console. 

       

      12:47:42,138 INFO  [STDOUT] INFO  18-10 12:47:42,137 (RepositoryServlet.java:allowUser:114) admin authenticated for rest api
      12:47:42,138 INFO  [STDOUT] INFO  18-10 12:47:42,138 (PackageDeploymentServlet.java:execute:141) PackageName: defaultPackage
      12:47:42,138 INFO  [STDOUT] INFO  18-10 12:47:42,138 (PackageDeploymentServlet.java:execute:142) PackageVersion: LATEST
      12:47:42,139 INFO  [STDOUT] INFO  18-10 12:47:42,138 (PackageDeploymentServlet.java:execute:143) PackageIsLatest: true
      12:47:42,139 INFO  [STDOUT] INFO  18-10 12:47:42,139 (PackageDeploymentServlet.java:execute:144) PackageIsSource: false
      12:47:42,226 INFO  [STDOUT] INFO  18-10 12:47:42,226 (NilAuthenticator.java:authenticate:35) All users are guests.
      12:47:42,227 INFO  [STDOUT] INFO  18-10 12:47:42,227 (RepositoryServlet.java:allowUser:114) admin authenticated for rest api
      12:47:42,227 INFO  [STDOUT] INFO  18-10 12:47:42,227 (PackageDeploymentServlet.java:execute:141) PackageName: gov.nc.osbm.ibis
      12:47:42,227 INFO  [STDOUT] INFO  18-10 12:47:42,227 (PackageDeploymentServlet.java:execute:142) PackageVersion: LATEST
      12:47:42,228 INFO  [STDOUT] INFO  18-10 12:47:42,227 (PackageDeploymentServlet.java:execute:143) PackageIsLatest: true
      12:47:42,228 INFO  [STDOUT] INFO  18-10 12:47:42,228 (PackageDeploymentServlet.java:execute:144) PackageIsSource: false

      12:47:42,239 INFO  [STDOUT] 12:47:42,239 ERROR [CommandDelegate] Could not load processes from Guvnor: null

      12:47:42,250 INFO  [STDOUT] 12:47:42,249 ERROR [CommandDelegate] jbpm.console.directory property not found

      12:47:42,281 INFO  [Configuration] Reading mappings from resource : META-INF/JBPMorm.xml

       

      Is there a configuration I need to change ?

        • 1. Re: JBPM console not displaying processes from my package
          Maciej Swiderski Master

          As far as I know console currently can access only artifacts from the defaultPackage so you should place your processes in that package. More over make sure that console successfully connects to Guvnor (make sure that changeset.xml file is available to the console). As you could see there is a problem with that:

           

          12:47:42,239 INFO  [STDOUT] 12:47:42,239 ERROR [CommandDelegate] Could not load processes from Guvnor: null

          HTH