8 Replies Latest reply on Oct 25, 2011 10:29 AM by Jesper Pedersen

    Porting legacy resource adapter from AS5 to AS7

    Daniel Rosowski Newbie

      Hello,

       

      I have an resource adapter that is currently in production using JEE 5 and JBoss 5. I tried to deploy the RA to JBoss 7.0.2 Final and (apparently) everything worked fine. Except that it didn't bind the adapter to the jndi name I gave it (tried both, the management console and the standalone.xml file). After that I read some posts regarding resource adapters on this forum, stating that a lot of work has been done on the connector and that JBoss 7.1.0 should be given a try. Now I get a warning, saying that the connection factory is not bound:

       

      17:26:54,495 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-7) Starting deployment of "legacy.rar"

      17:26:54,526 WARN  [org.jboss.as.connector.deployers.RaXmlDeployer] (MSC service thread 1-7) IJ020013: Connection factory not bound: com.mycom.connector.legacy.LegacyManagedConnectionFactory

      17:26:54,526 INFO  [org.jboss.as.connector.deployers.RaXmlDeployer] (MSC service thread 1-7) IJ020002: Deployed: file:/C:/dev/jboss-as-7.1.0.Alpha2-SNAPSHOT/standalone/tmp/vfs/tempb202cc793b492ddb/legacy.rar-471bb98c321bac8a/contents/

      17:26:54,542 INFO  [org.jboss.as.server.controller] (DeploymentScanner-threads - 2) Deployed "legacy.rar"

       

      Any general hints on what to check on for the migration of resource adapters to JBoss 7?

       

      Cheers,

      Daniel