2 Replies Latest reply on Oct 26, 2011 9:19 AM by L48FSR frosini

    Jboss 5.1 remote - Junit - IntelliJ Idea 10 - Arquillian Alpha5

    L48FSR frosini Newbie

      Hi everyone,

      I've got a problem with this configuration:

       

      - Jboss 5.1.0 GA

      - Arquillian Alpha5

      - Junit 4.8.1

      - IntelliJ Idea 10

      - MacOs Lion

       

      When I execute my arquillian test with Junit framework the result is always passed.

       

      This is my pom.xml:

       

      <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

        xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">

       

        <modelVersion>4.0.0</modelVersion>

       

        <groupId>MyFirstAQProject</groupId>

        <artifactId>MyFirstAQProject</artifactId>

        <version>1.0.0.Alpha5</version>

        <packaging>jar</packaging>

       

        <name>MyFirstAQProject</name>

        <url>http://maven.apache.org</url>

       

        <properties>

          <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>

          <arquillian.version>1.0.0.Alpha5</arquillian.version>

        </properties>

       

        <dependencies>  

          <dependency>

              <groupId>javax.enterprise</groupId>

              <artifactId>cdi-api</artifactId>

              <version>1.0-SP1</version>

              <optional>false</optional>

          </dependency>

          <dependency>

              <groupId>org.jboss.arquillian</groupId>

              <artifactId>arquillian-junit</artifactId>

              <version>1.0.0.Alpha5</version>

              <scope>test</scope>

              <optional>false</optional>

          </dependency>

          <dependency>

              <groupId>junit</groupId>

              <artifactId>junit</artifactId>

              <version>4.8.1</version>

              <scope>test</scope>

              <optional>false</optional>

          </dependency>

        </dependencies>

       

       

      <profiles>

          <profile>

              <id>jbossas-remote-51</id>

              <dependencies>

                  <dependency>

                      <groupId>org.jboss.arquillian.container</groupId>

                      <artifactId>arquillian-jbossas-remote-5.1</artifactId>

                      <version>1.0.0.Alpha5</version>

                      <scope>test</scope>

                  </dependency>

                  <dependency>

                      <groupId>org.jboss.jbossas</groupId>

                      <artifactId>jboss-as-client</artifactId>

                      <version>5.1.0.GA</version>

                      <type>test</type>

                  </dependency>

              </dependencies>

          </profile>

        </profiles>

        <repositories>

            <repository>

                <id>jboss-public-repository-group</id>

                <name>JBoss Public Repository Group</name>

                <url>http://repository.jboss.org/nexus/content/groups/public/</url>

                <layout>default</layout>

            </repository>

            <repository>

                <releases>

                    <enabled>true</enabled>

                </releases>

                <snapshots>

                    <enabled>false</enabled>

                </snapshots>

                <id>jboss-central</id>

                <name>JBoss Central</name>

                <url>https://repository.jboss.org/nexus/content/repositories/central/</url>

                <layout>default</layout>

            </repository>

            <repository>

                <releases>

                    <enabled>true</enabled>

                </releases>

                <snapshots>

                    <enabled>false</enabled>

                </snapshots>

                <id>jboss-deprecated</id>

                <name>JBoss Deprecated</name>

                <url>https://repository.jboss.org/nexus/content/repositories/deprecated/</url>

                <layout>default</layout>

            </repository>

            <repository>

                <releases>

                    <enabled>true</enabled>

                </releases>

                <snapshots>

                    <enabled>false</enabled>

                </snapshots>

                <id>jboss-public</id>

                <name>JBoss Public</name>

                <url>https://repository.jboss.org/nexus/content/repositories/public-jboss/</url>

                <layout>default</layout>

            </repository>

        </repositories>

      </project>

       

      This is my arquillian.xml:

       

      <?xml version="1.0" encoding="UTF-8"?>

      <arquillian xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

          xsi:schemaLocation="http://jboss.org/schema/arquillian http://jboss.org/schema/arquillian/arquillian-1.0.xsd">

          <engine>

              <property name="deploymentExportPath">default</property>

          </engine>

       

          <container qualifier="jboss" default="true">

              <configuration>

                  <property name="profileName">default</property>

                  <property name="providerUrl">jnp://localhost:1099</property>

                  <property name="urlPkgPrefix">org.jnp.interfaces</property>

                  <property name="contextFactory">org.jnp.interfaces.NamingContextFactory</property>

              </configuration>

          </container>

      </arquillian>

       

      This is my basic test class (for the moment I don't inject the ejb using @EJB....):

       

      @RunWith(Arquillian.class)

      public class BoPlatformManagerBean

      {

          @Deployment

          @TargetsContainer("jboss")

          public static JavaArchive createTestArchive()

          {

              return ShrinkWrap.create(JavaArchive.class, "test.jar");

          }

       

          @Test

          public void primoTest()

          {

              System.out.println("TEST");

              Assert.assertTrue(false);

          }

      }

       

      This is jboss server output:

       

      16:52:44,888 INFO  [DeployHandler] Remove, [test.ear]

      16:53:01,103 INFO  [DeployHandler] Handle stream, deploymentTarget: names=[test.ear], copyContent=true, description=file:/var/folders/l7/h_qg6jp5511f7vbd3j2hv17r0000gn/T/arquillian9162589038280258026test.ear/test.ear

      16:53:01,247 INFO  [DeployHandler] End handle stream, repositoryName: vfszip:/Applications/jboss-5/server/default/deploy/test.ear/

      16:53:01,265 INFO  [DeployHandler] Begin start, [test.ear]

      16:53:01,632 INFO  [TomcatDeployment] deploy, ctxPath=/arquillian-protocol

      16:53:01,657 INFO  [DeployHandler] End start, [vfszip:/Applications/jboss-5/server/default/deploy/test.ear/]

      16:53:01,851 WARN  [AbstractManagedObjectPopulator] Cannot create String name from non-Simple property: ManagedProperty{JNDIName,JNDIName,metaType=SimpleMetaType:java.lang.String}, value=null

      16:53:01,855 WARN  [AbstractManagedObjectPopulator] Cannot create String name from non-Simple property: ManagedProperty{JNDIName,JNDIName,metaType=SimpleMetaType:java.lang.String}, value=null

      16:53:03,164 INFO  [DeployHandler] Stop, [test.ear]

      16:53:03,165 INFO  [TomcatDeployment] undeploy, ctxPath=/arquillian-protocol

      16:53:03,190 INFO  [DeployHandler] End stop, [vfszip:/Applications/jboss-5/server/default/deploy/test.ear/]

      16:53:03,208 INFO  [DeployHandler] Remove, [test.ear]

       

      Where is my error ?

      Thanks