1 Reply Latest reply on Oct 26, 2011 10:19 AM by Xavier Goupil

    [Resolved] Jboss 5.1 cluster parameters problem

    Xavier Goupil Newbie

      Hi !

       

      I got a new problem with jboss 5.1 with jdk 1.5.22 on a windows 2000 terminal server.

      Thisproblem occure when launching the first node of the cluster.

       

      I declare specific element for my cluster in my service.bat :

       

      set JAVA_OPTS=-Xrs -Xms256m -Xmx768m -XX:MaxPermSize=256m -XX:+AggressiveOpts -XX:+UseFastAccessorMethods -XX:+UseParallelGC

      set JAVA_OPTS=%JAVA_OPTS% -Djboss.bind.address=%IP_HOST% -Djgroups.bind_addr=%IP_HOST% -Djboss.service.binding.set=ports-default -Djboss.partition.name=MY_CLUSTER

      set JAVA_OPTS=%JAVA_OPTS% -Djboss.messaging.ServerPeerID=%NUM_INST% -Djboss.jgroups.enable_diagnostics=false -Djboss.jgroups.tcp.tcp_port=%TCP_PORT% -Djboss.partition.udpGroup=230.1.2.7

      set JAVA_OPTS=%JAVA_OPTS% -Djava.net.preferIPv4Stack=true -Djboss.default.jgroups.stack=tcp -Djgroups.tcpping.initial_hosts=%IP_HOST%[%TCP_PORT%],%IP_HOST%[%BROTHER_PORT%],%PART_HOST%[7810],%PART_HOST%[7910]

      set JAVA_OPTS=%JAVA_OPTS% -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000

       

      TCP_PORT = 7810

      BROTHER_PORT=7910

      IP_HOST=XXX.XXX.XXX.XXX

      PART_HOST=XXX.XXX.XXX.XXX

       

      And here is the error I got :

       

      2011-10-26 12:59:10,364 DEBUG [org.jgroups.protocols.FRAG2] received CONFIG event: {additional_data=[B@13a70db}

      2011-10-26 12:59:10,582 INFO  [org.jboss.ha.framework.interfaces.HAPartition.MY_CLUSTER] Initializing partition MY_CLUSTER

      2011-10-26 12:59:10,614 DEBUG [org.jboss.ha.framework.interfaces.HAPartition.MY_CLUSTER] setMembershipListener

      2011-10-26 12:59:10,614 DEBUG [org.jboss.ha.framework.interfaces.HAPartition.MY_CLUSTER] setMessageListener

      2011-10-26 12:59:10,645 DEBUG [org.jgroups.protocols.TCP] received CONFIG event: {flush_supported=true}

      2011-10-26 12:59:10,645 DEBUG [org.jgroups.protocols.FRAG2] received CONFIG event: {flush_supported=true}

      2011-10-26 12:59:10,676 DEBUG [org.jgroups.blocks.ConnectionTable] server socket listening on XXX.XXX.XXX.XXX:7810

      2011-10-26 12:59:10,676 DEBUG [org.jgroups.protocols.TCPPING] [SET_LOCAL_ADDRESS]: removing my own address (10.172.35.243:7810) from initial_hosts; initial_hosts=[XXX.XXX.XXX.XXX:7910, XXX.XXX.XXX.XXX:7810, XXX.XXX.XXX.XXX:7910]

      2011-10-26 12:59:10,676 DEBUG [org.jboss.ha.framework.interfaces.HAPartition.MY_CLUSTER] Block processed at null

      2011-10-26 12:59:10,832 INFO  [org.jgroups.JChannel] JGroups version: 2.6.10.GA

      2011-10-26 12:59:10,832 DEBUG [org.jgroups.protocols.pbcast.GMS] changed role to org.jgroups.protocols.pbcast.ClientGmsImpl

      2011-10-26 12:59:10,832 DEBUG [org.jgroups.protocols.FRAG2] frag_size=60000, new frag_size=60000

      2011-10-26 12:59:10,832 DEBUG [org.jboss.ha.framework.server.JChannelFactory] Fixed thread factory for TCP(local address: XXX.XXX.XXX.XXX:7810)

      2011-10-26 12:59:10,832 DEBUG [org.jboss.ha.framework.server.JChannelFactory] Fixed timer thread factory for TCP(local address: XXX.XXX.XXX.XXX:7810)

      2011-10-26 12:59:10,832 DEBUG [org.jboss.ha.framework.server.JChannelFactory] Fixed default pool thread factory for TCP(local address: XXX.XXX.XXX.XXX:7810)

      2011-10-26 12:59:10,848 DEBUG [org.jboss.ha.framework.server.JChannelFactory] Fixed oob pool thread factory for TCP(local address: XXX.XXX.XXX.XXX:7810)

      2011-10-26 12:59:10,848 DEBUG [org.jboss.ha.framework.server.JChannelFactory] Fixed Protocol thread factories

      2011-10-26 12:59:10,848 DEBUG [org.jboss.ha.framework.server.JChannelFactory] Passing unique node id XXX.XXX.XXX.XXX:1099 to the channel as additional data

      2011-10-26 12:59:10,848 DEBUG [org.jgroups.protocols.TCP] received CONFIG event: {additional_data=[B@421a7e}

      2011-10-26 12:59:10,848 DEBUG [org.jgroups.protocols.FRAG2] received CONFIG event: {additional_data=[B@421a7e}

      2011-10-26 12:59:10,926 DEBUG [org.jgroups.protocols.TCP] received CONFIG event: {flush_supported=true}

      2011-10-26 12:59:10,926 DEBUG [org.jgroups.protocols.FRAG2] received CONFIG event: {flush_supported=true}

      2011-10-26 12:59:10,926 DEBUG [org.jgroups.protocols.TCPPING] [SET_LOCAL_ADDRESS]: removing my own address (10.172.35.243:7810) from initial_hosts; initial_hosts=[XXX.XXX.XXX.XXX:7910, XXX.XXX.XXX.XXX:7810, XXX.XXX.XXX.XXX:7910]

      2011-10-26 12:59:13,207 ERROR [org.jgroups.blocks.ConnectionTable] failed sending data to 0.0.0.0:7810: java.net.SocketException: Socket closed

      2011-10-26 12:59:13,379 DEBUG [org.jgroups.protocols.pbcast.GMS] initial_mbrs are [[own_addr=0.0.0.0:7810, coord_addr=0.0.0.0:7810, is_server=true]]

      2011-10-26 12:59:13,379 DEBUG [org.jgroups.protocols.pbcast.GMS] initial_mbrs are [[own_addr=0.0.0.0:7810, coord_addr=0.0.0.0:7810, is_server=true]]

      2011-10-26 12:59:13,379 DEBUG [org.jgroups.protocols.pbcast.GMS] election results: {0.0.0.0:7810=1}

      2011-10-26 12:59:13,379 DEBUG [org.jgroups.protocols.pbcast.GMS] election results: {0.0.0.0:7810=1}

      2011-10-26 12:59:13,379 DEBUG [org.jgroups.protocols.pbcast.GMS] sending handleJoin(XXX.XXX.XXX.XXX:7810) to 0.0.0.0:7810

      2011-10-26 12:59:13,379 DEBUG [org.jgroups.protocols.pbcast.GMS] sending handleJoin(XXX.XXX.XXX.XXX:7810) to 0.0.0.0:7810

      2011-10-26 12:59:16,442 WARN  [org.jgroups.protocols.pbcast.GMS] join(XXX.XXX.XXX.XXX:7810) sent to 0.0.0.0:7810 timed out (after 3000 ms), retrying

      2011-10-26 12:59:16,442 WARN  [org.jgroups.protocols.pbcast.GMS] join(XXX.XXX.XXX.XXX:7810) sent to 0.0.0.0:7810 timed out (after 3000 ms), retrying

      So why my cluster try to use 0.0.0.0 instead of the IP adress given in the service ?

       

      If you have some advice and idea to correct this it will be great.

       

      Xavier.