0 Replies Latest reply on Oct 26, 2011 9:15 AM by jonis1974

    E_FAILED_TO_GET_DATASOURCE Error - JBoss & Filenet

    jonis1974 Newbie

      Hi everybody,

       

      since April 2009 we've got a J2EE application that accesses a Filenet P8 Content Engine (4.0

       

      ) running on a JBoss AS.

       

      We had not had any problems with the infraestructure until a month ago, when the activity (accesses) in the Filenet system increased. Since this happened we have seen that in the JBoss logs always appears the message:

       

      "2011-10-25 08:58:19,172 ERROR [org.jboss.ejb.plugins.LogInterceptor] RuntimeException in method: public abstract com.filenet.apiimpl.transport.ExecuteChangesResponse com.filenet.engine.ejb.EngineCoreLocal.executeChanges(com.filenet.apiimpl.transport.ClientCallContext,com.filenet.apiimpl.transport.ExecuteChangesRequest):

      com.filenet.api.exception.EngineRuntimeException: E_FAILED_TO_GET_DATASOURCE: Failed to get DataSource java:jdbc/PoolDarXA."

       

      A week ago we increased the size of the connection pool and we have seen that the pool is big enough now to support the users accessing the system, but the problem and the message still appear.

       

      We have also seen that other error messages appear mixed with the one stated before:

       

      "2011-10-25 08:58:19,157 WARN  [org.jboss.tm.TransactionImpl] XAException: tx=TransactionImpl:XidImpl[FormatId=257, GlobalId=WNDARP02/83, BranchQual=, localId=83] errorCode=XA_UNKNOWN(0)

      javax.transaction.xa.XAException: java.sql.SQLException: DTC_XA_START:No transaction cookie returned"

       

      "2011-10-25 08:58:19,172 WARN  [org.jboss.tm.TransactionImpl] XAException: tx=TransactionImpl:XidImpl[FormatId=257, GlobalId=WNDARP02/83, BranchQual=, localId=83] errorCode=XA_UNKNOWN(0)

      javax.transaction.xa.XAException: java.sql.SQLException: ROLLBACK:Status:0 msg:*** SQLJDBC_XA DTC_ERROR Context: xa_rollback, state=1, StatusCode:-4 (0xFFFFFFFC) ***"

       

      The database is MS SQL Server (version 9.00.3042), the driver is MS SQL Server 2005 JDBC Driver (version 1.2.2828.203) and the datasource configurations are:

      <datasources>

      <xa-datasource>

      <jndi-name>jdbc/PoolDarXA</jndi-name>

      <track-connection-by-tx></track-connection-by-tx>

      <isSameRM-override-value>false</isSameRM-override-value>

      <xa-datasource-class>com.microsoft.sqlserver.jdbc.SQLServerXADataSource</xa-datasource-class>

      <xa-datasource-property name="ServerName">10.30.2.234</xa-datasource-property>

      <xa-datasource-property name="PortNumber">1433</xa-datasource-property>

      <xa-datasource-property name="DatabaseName">CE_DAR</xa-datasource-property>

      <xa-datasource-property name="SelectMethod">cursor</xa-datasource-property>

      <user-name>ce_login</user-name>

      <password>XXXXXXX</password>

      <min-pool-size>10</min-pool-size>

      <max-pool-size>100</max-pool-size>

      <idle-timeout-minutes>5</idle-timeout-minutes>

      <check-valid-connection-sql>select count(*) from SysObjects</check-valid-connection-sql>

      <!-- corresponding type-mapping in the standardjbosscmp-jdbc.xml (optional) -->

      <metadata>

      <type-mapping>MS SQLSERVER</type-mapping>

      </metadata>

      </xa-datasource>

      </datasources>

       

      <datasources>

      <xa-datasource>

      <jndi-name>jdbc/PoolGCDJ_XA</jndi-name>

      <track-connection-by-tx></track-connection-by-tx>

      <isSameRM-override-value>false</isSameRM-override-value>

      <xa-datasource-class>com.microsoft.sqlserver.jdbc.SQLServerXADataSource</xa-datasource-class>

      <xa-datasource-property name="ServerName">10.30.2.234</xa-datasource-property>

      <xa-datasource-property name="PortNumber">1433</xa-datasource-property>

      <xa-datasource-property name="DatabaseName">GCDJ</xa-datasource-property>

      <xa-datasource-property name="SelectMethod">cursor</xa-datasource-property>

      <user-name>ce_login</user-name>

      <password>XXXXXXX</password>

      <min-pool-size>10</min-pool-size>

      <max-pool-size>50</max-pool-size>

      <check-valid-connection-sql>select count(*) from SysObjects</check-valid-connection-sql>

      <!-- corresponding type-mapping in the standardjbosscmp-jdbc.xml (optional) -->

      <metadata>

      <type-mapping>MS SQLSERVER</type-mapping>

      </metadata>

      </xa-datasource>

      </datasources>

       

      I would like to know if anybody knows what else has to be done just not to get these datasource access errors. If you need more information to help me solve the problem please tell me. Thank you in advance.