1 Reply Latest reply on Oct 9, 2009 9:32 AM by Ilya Shaikovsky

    Problem with ContextMenu

    ayesa act sistemas Newbie

      Hello,

      I have a problem with the ContexMenu in a page with a table that is loaded with ajax. Version 3.3.0GA shows the context menu correctly but version 3.3.1GA does not shows and version 3.3.2GA only show in firefox the context menu.

      When not showing the context menu, I click on the page CTRL + F5 the next time you load the table with ajax it shows the context menu when you click on a row.


      I don't know that I may be doing wrong and because 3.3.0GA version it works.

      My context menu code is:

      <rich:contextMenu attached="false" id="menuContextualVehiculos" submitMode="ajax">
       <rich:menuItem value="Modificar" action="#{listaVehiculosBean.modificarVehiculo}" ajaxSingle="true">
       <a4j:actionparam name="sid" assignTo="#{listaVehiculosBean.vhSid}" value="{vhSid}"/>
       </rich:menuItem>
       <rich:menuItem value="Consultar" action="#{listaVehiculosBean.consultarVehiculo}" ajaxSingle="true">
       <a4j:actionparam name="sid" assignTo="#{listaVehiculosBean.vhSid}" value="{vhSid}"/>
       </rich:menuItem>
      </rich:contextMenu>
      


      My table code is:
      <rich:dataTable ... >
      ...
      
       <rich:componentControl event="onRowClick" for="menuContextualVehiculos" operation="show">
       <f:param value="#{vh.sid}" name="vhSid"/>
       </rich:componentControl>
      </rich:dataTable>
      

      I will appreciate much your help.

      Thanks.