0 Replies Latest reply on Oct 31, 2011 6:12 AM by trinorae

    ExtendedDataTable remove extra column issues with grouping and header-facet

    trinorae Newbie

      Hello

       

       

      I was trying to remove the extra column in the ExtendedDataTables, since we don't need the resizing functionality and the extra column was bottering us. I am using richfaces version 3.3.3.Final.

      So I did some research and tried some CSS-code to get rid of it. I did the following:

       

      .extdt-empty-cell {
          width: 0;
      }
      
      th.extdt-empty-cell {
          width: 0;
      }
      
      /* Disables resizing */
      .extdt-hsep {
          display: none;
      }
      

       

      At first sight this seemed to work great. But in certain situation, it appears that the extra columns still are visible and I really can't get rid of them.

       

      The first case where this occurs is when I "group by column". Grouping by any column seems to revive the extra column. What makes the problem worse is that the extra column only appears in the "data" of the table, but not in the headers, making the layout a total mess. (Since the header row has one column less than the body-rows)

       

      The second case costed me some time to find out. I have an extra column in my header, but not in my body. (So the opposite situation of the above) After stripping out everything from the datatable I found out it was caused by the header-facet of the table itself! Removing it, fixed the issue. For this one I luckely found a workaround. Since I can disable the extra column, but need the header-message, I've put a rich:panel with customized CSS around the datatable. This panel contains the header-message for the table.

       

      Does anyone know why this issues arise or how I can get rid of them? The first issue in particular is bottering me, since I don't have a workaround for that one.

       

      Edit: I just looked at it in IE8. The CSS-fix for the extra column seems to behave extremely weird in that browser. In some cases the extra column does appear, in other it doesn't. (Long live IE...) I think the whole CSS-solution isn't that good. If there's anyone who has a better solution, I'll be happy to hear it.

       

       

      Kind regards,

      Stef