4 Replies Latest reply on Nov 3, 2011 6:42 PM by joe lau

    JBoss 7 upgrade - Caused by: java.lang.RuntimeException: SAX2 driver class org.apache.xerces.parsers.SAXParser not found

    joe lau Newbie

      I am trying to make a massive update from jboss 4.2.3 to jboss 7. I have been able to get past most of the reconfiguration but there is a runtime error that I am encountering. Caused by: java.lang.RuntimeException: SAX2 driver class org.apache.xerces.parsers.SAXParser not found

      I've tried the suggestions from this other article but to no avail. http://community.jboss.org/message/616226

       

      Stack Trace:

      ===============================================================================
      
        JBoss Bootstrap Environment
      
        JBOSS_HOME: C://projects//buildenv//jboss//jboss-as-web-7.0.2.Final
      
        JAVA: C:\Program Files\Java\jdk1.6.0_26\bin\java
      
        JAVA_OPTS: -Dprogram.name=standalone.bat  -server -Xms512M -Xmx1024M -XX:PermSize=192M -Xdebug -Xrunjdwp:transport=dt_
      socket,server=y,suspend=n,address=8788 -Dorg.xml.sax.driver=org.apache.xerces.parsers.SAXParser -Djava.io.tmpdir=c:/temp
       -XX:MaxPermSize=256M -DbaseDirectory=c:/run -Djboss.server.base.url=file:///c:/
      run/server/config/jboss-as-web-7.0.2.Final -Djboss.server.base.dir=c:
      /run/server/config/jboss-as-web-7.0.2.Final -Dfile.encoding=utf-8 -server
      
      ===============================================================================
      
      Listening for transport dt_socket at address: 8788
      Exception in thread "main" java.lang.ExceptionInInitializerError
              at __redirected.__JAXPRedirected.initAll(__JAXPRedirected.java:89)
              at org.jboss.modules.Module$1.run(Module.java:88)
              at org.jboss.modules.Module$1.run(Module.java:75)
              at java.security.AccessController.doPrivileged(Native Method)
              at org.jboss.modules.Module.<clinit>(Module.java:75)
              at org.jboss.modules.Main.main(Main.java:257)
      Caused by: java.lang.RuntimeException: SAX2 driver class org.apache.xerces.parsers.SAXParser not found
              at org.xml.sax.helpers.XMLReaderFactory.loadClass(XMLReaderFactory.java:189)
              at org.xml.sax.helpers.XMLReaderFactory.createXMLReader(XMLReaderFactory.java:150)
              at __redirected.__XMLReaderFactory.<clinit>(__XMLReaderFactory.java:73)
              ... 6 more
      Caused by: java.lang.ClassNotFoundException: org.apache.xerces.parsers.SAXParser
              at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
              at java.security.AccessController.doPrivileged(Native Method)
              at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
              at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
              at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
              at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
              at org.xml.sax.helpers.NewInstance.newInstance(NewInstance.java:49)
              at org.xml.sax.helpers.XMLReaderFactory.loadClass(XMLReaderFactory.java:187)
              ... 8 more
      
      

       

      Standalone.xml:

      <?xml version='1.0' encoding='UTF-8'?>
      
      <server name="jlau" xmlns="urn:jboss:domain:1.0">
          <extensions>
              <extension module="org.jboss.as.clustering.infinispan" />
              <extension module="org.jboss.as.connector" />
              <extension module="org.jboss.as.deployment-scanner" />
              <extension module="org.jboss.as.ee" />
              <extension module="org.jboss.as.ejb3" />
              <extension module="org.jboss.as.jaxrs" />
              <extension module="org.jboss.as.jmx" />
              <extension module="org.jboss.as.jpa" />
              <extension module="org.jboss.as.logging" />
              <extension module="org.jboss.as.naming" />
              <extension module="org.jboss.as.osgi" />
              <extension module="org.jboss.as.pojo" />
              <extension module="org.jboss.as.remoting" />
              <extension module="org.jboss.as.sar" />
              <extension module="org.jboss.as.security" />
              <extension module="org.jboss.as.threads" />
              <extension module="org.jboss.as.transactions" />
              <extension module="org.jboss.as.web" />
              <extension module="org.jboss.as.weld" />
          </extensions>
          <management>
              <security-realms>
                  <security-realm name="PropertiesMgmtSecurityRealm">
                      <authentication>
                          <properties path="mgmt-users.properties" relative-to="jboss.server.config.dir" />
                      </authentication>
                  </security-realm>
              </security-realms>
              <management-interfaces>
                  <native-interface interface="management" port="9999" />
                  <http-interface interface="management" port="9990" />
              </management-interfaces>
          </management>
          <profile>
              <subsystem xmlns="urn:jboss:domain:logging:1.1">
                  <console-handler name="CONSOLE" autoflush="true">
                      <level name="INFO" />
                      <formatter>
                          <pattern-formatter pattern="%d{HH:mm:ss,SSS} %-5p [%c] (%t) %s%E%n" />
                      </formatter>
                  </console-handler>
                  <periodic-rotating-file-handler name="FILE"
                      autoflush="true">
                      <level name="INFO" />
                      <formatter>
                          <pattern-formatter pattern="%d{HH:mm:ss,SSS} %-5p [%c] (%t) %s%E%n" />
                      </formatter>
                      <file relative-to="jboss.server.log.dir" path="server.log" />
                      <suffix value=".yyyy-MM-dd" />
                      <append value="true" />
                  </periodic-rotating-file-handler>
                  <logger category="com.arjuna">
                      <level name="WARN" />
                  </logger>
                  <logger category="org.apache.tomcat.util.modeler">
                      <level name="WARN" />
                  </logger>
                  <logger category="sun.rmi">
                      <level name="WARN" />
                  </logger>
                  <root-logger>
                      <level name="INFO" />
                      <handlers>
                          <handler name="CONSOLE" />
                          <handler name="FILE" />
                      </handlers>
                  </root-logger>
              </subsystem>
              <subsystem xmlns="urn:jboss:domain:datasources:1.0">
                  <datasources>
                      <datasource jndi-name="java:jboss/datasources/ExampleDS"
                          pool-name="H2DS" enabled="true" jta="true" use-java-context="true"
                          use-ccm="true">
                          <connection-url>
                              jdbc:h2:mem:test;DB_CLOSE_DELAY=-1
                          </connection-url>
                          <driver>
                              h2
                          </driver>
                          <pool>
                              <prefill>
                                  false
                              </prefill>
                              <use-strict-min>
                                  false
                              </use-strict-min>
                              <flush-strategy>
                                  FailingConnectionOnly
                              </flush-strategy>
                          </pool>
                          <security>
                              <user-name>
                                  sa
                              </user-name>
                              <password>
                                  sa
                              </password>
                          </security>
                      </datasource>
                      <!-- converted from jboss.4.2.3's mssql-ds.xml -->
                      <xa-datasource jndi-name="jdbc/BuildingCenterBizDS_baseline"
                          pool-name="BuildingCenterBizDS_baseline" enabled="true"
                          use-java-context="true" use-ccm="true">
                          <xa-datasource-property name="DatabaseName">
                              @install.biz_db.database@
                          </xa-datasource-property>
                          <xa-datasource-property name="PrepareSql">
                              2
                          </xa-datasource-property>
                          <xa-datasource-property name="UseLOBs">
                              false
                          </xa-datasource-property>
                          <xa-datasource-property name="ServerName">
                              @install.biz_db.server@
                          </xa-datasource-property>
                          <xa-datasource-property name="XaEmulation">
                              true
                          </xa-datasource-property>
                          <xa-datasource-property name="Tds">
                              8.0
                          </xa-datasource-property>
                          <xa-datasource-class>
                              @install.jdbcx.driver.class@
                          </xa-datasource-class>
                          <driver>
                              jtds
                          </driver>
                          <xa-pool>
                              <is-same-rm-override>false</is-same-rm-override>
                              <min-pool-size>5</min-pool-size>
                              <max-pool-size>1000</max-pool-size>
                          </xa-pool>
                          <timeout>
                              <blocking-timeout-millis>5000</blocking-timeout-millis>
                              <idle-timeout-minutes>10</idle-timeout-minutes>
                          </timeout>
                          <validation>
                              <check-valid-connection-sql>SELECT 1</check-valid-connection-sql>
                          </validation>
                          <security>
                              <user-name>
                                  @install.biz_db.username@
                              </user-name>
                              <password>
                                  @install.biz_db.password@
                              </password>
                          </security>
                      </xa-datasource>
                      <!-- converted from jboss.4.2.3's mssql-ds.xml -->
                      
      <xa-datasource jndi-name="jdbc/BuildingCenterMetaDS" pool-name="BuildingCenterMetaDS_Pool" enabled="true" use-java-context="true" use-ccm="true">
                          <xa-datasource-property name="DatabaseName">
                              @install.meta_db.database@
                          </xa-datasource-property>
                          <xa-datasource-property name="PrepareSql">
                              2
                          </xa-datasource-property>
                          <xa-datasource-property name="UseLOBs">
                              false
                          </xa-datasource-property>
                          <xa-datasource-property name="ServerName">
                              @install.meta_db.server@
                          </xa-datasource-property>
                          <xa-datasource-property name="XaEmulation">
                              true
                          </xa-datasource-property>
                          <xa-datasource-property name="Tds">
                              8.0
                          </xa-datasource-property>
                          <xa-datasource-class>
                              @install.jdbcx.driver.class@
                          </xa-datasource-class>
                          <driver>
                              jtds
                          </driver>
                          <xa-pool>
                              <is-same-rm-override>false</is-same-rm-override>
                              <min-pool-size>5</min-pool-size>
                              <max-pool-size>1000</max-pool-size>
                          </xa-pool>
                          <security>
                              <user-name>
                                  @install.meta_db.username@
                              </user-name>
                              <password>
                                  @install.meta_db.password@
                              </password>
                          </security>
                      </xa-datasource>
                      
                      <drivers>
                          <driver name="jtds" module="net.sourceforge.jtds">
                              <xa-datasource-class>
                                  net.sourceforge.jtds.jdbcx.JdbcDataSource
                              </xa-datasource-class>
                          </driver>
                          <driver name="hsqldb" module="org.hsqldb">
                              <xa-datasource-class>
                                  org.hsqldb.jdbc.jdbcDataSource
                              </xa-datasource-class>
                          </driver>
                          <driver name="h2" module="com.h2database.h2">
                              <xa-datasource-class>
                                  org.h2.jdbcx.JdbcDataSource
                              </xa-datasource-class>
                          </driver>
                      </drivers>
                  </datasources>
              </subsystem>
              <subsystem xmlns="urn:jboss:domain:deployment-scanner:1.0">
                  <deployment-scanner name="default" path="deployments"
                      scan-enabled="true" scan-interval="5000" relative-to="jboss.server.base.dir"
                      deployment-timeout="60" />
              </subsystem>
              <subsystem xmlns="urn:jboss:domain:ee:1.0" />
              <subsystem xmlns="urn:jboss:domain:ejb3:1.1" lite="true">
                  <session-bean>
                      <stateless>
                          <bean-instance-pool-ref pool-name="slsb-strict-max-pool" />
                      </stateless>
                  </session-bean>
                  <pools>
                      <bean-instance-pools>
                          <strict-max-pool name="slsb-strict-max-pool"
                              max-pool-size="20" instance-acquisition-timeout="5"
                              instance-acquisition-timeout-unit="MINUTES" />
                      </bean-instance-pools>
                  </pools>
              </subsystem>
              <subsystem xmlns="urn:jboss:domain:infinispan:1.0"
                  default-cache-container="hibernate">
                  <cache-container name="hibernate" default-cache="local-query">
                      <local-cache name="entity">
                          <eviction strategy="LRU" max-entries="10000" />
                          <expiration max-idle="100000" />
                      </local-cache>
                      <local-cache name="local-query">
                          <eviction strategy="LRU" max-entries="10000" />
                          <expiration max-idle="100000" />
                      </local-cache>
                      <local-cache name="timestamps">
                          <eviction strategy="NONE" />
                      </local-cache>
                  </cache-container>
              </subsystem>
              <subsystem xmlns="urn:jboss:domain:jaxrs:1.0" />
              <subsystem xmlns="urn:jboss:domain:jca:1.0">
                  <archive-validation enabled="false" />
                  <bean-validation enabled="false" />
                  <default-workmanager>
                      <short-running-threads blocking="true"
                          allow-core-timeout="false">
                          <core-threads count="10" per-cpu="20" />
                          <queue-length count="10" per-cpu="20" />
                          <max-threads count="10" per-cpu="20" />
                          <keepalive-time time="10" unit="SECONDS" />
                      </short-running-threads>
                      <long-running-threads blocking="true"
                          allow-core-timeout="false">
                          <core-threads count="10" per-cpu="20" />
                          <queue-length count="10" per-cpu="20" />
                          <max-threads count="10" per-cpu="20" />
                          <keepalive-time time="10" unit="SECONDS" />
                      </long-running-threads>
                  </default-workmanager>
              </subsystem>
              <subsystem xmlns="urn:jboss:domain:jmx:1.0">
                  <jmx-connector server-binding="jmx-connector-server"
                      registry-binding="jmx-connector-registry" />
              </subsystem>
              <subsystem xmlns="urn:jboss:domain:jpa:1.0">
                  <jpa default-datasource="" />
              </subsystem>
              <subsystem xmlns="urn:jboss:domain:naming:1.0" />
              <subsystem xmlns="urn:jboss:domain:pojo:1.0" />
              <subsystem xmlns="urn:jboss:domain:osgi:1.0" activation="lazy">
                  <configuration
                      pid="org.apache.felix.webconsole.internal.servlet.OsgiManager">
                      <property name="manager.root">
                          jboss-osgi
                      </property>
                  </configuration>
                  <properties>
                      <property name="org.jboss.osgi.system.modules">
                          org.apache.commons.logging,
                          org.apache.log4j,
                          org.jboss.as.osgi,
                          org.slf4j,
                      </property>
                      <property name="org.osgi.framework.startlevel.beginning">
                          1
                      </property>
                      <property name="org.osgi.framework.system.packages.extra">
                          org.apache.commons.logging;version=1.1.1,
                          org.apache.log4j;version=1.2,
                          org.jboss.as.osgi.service;version=7.0,
                          org.jboss.osgi.deployment.interceptor;version=1.0,
                          org.jboss.osgi.spi.capability;version=1.0,
                          org.jboss.osgi.spi.util;version=1.0,
                          org.jboss.osgi.testing;version=1.0,
                          org.jboss.osgi.vfs;version=1.0,
                          org.slf4j;version=1.5.10,
                      </property>
                  </properties>
                  <modules>
                      <module identifier="javaee.api" />
                      <module identifier="org.jboss.logging" />
                      <module identifier="org.apache.aries.util" />
                      <module identifier="org.apache.xerces.parsers" />
                      <module identifier="org.jboss.osgi.webconsole" />
                      <module identifier="org.osgi.compendium" />
                      <module identifier="org.apache.felix.log" startlevel="1" />
                      <module identifier="org.jboss.osgi.logging" startlevel="1" />
                      <module identifier="org.apache.felix.configadmin" startlevel="1" />
                      <module identifier="org.jboss.as.osgi.configadmin"
                          startlevel="1" />
                      <module identifier="org.apache.aries.jmx" startlevel="2" />
                      <module identifier="org.apache.felix.eventadmin" startlevel="2" />
                      <module identifier="org.apache.felix.metatype" startlevel="2" />
                      <module identifier="org.apache.felix.scr" startlevel="2" />
                      <module identifier="org.apache.felix.webconsole" startlevel="2" />
                      <module identifier="org.jboss.osgi.jmx" startlevel="2" />
                      <module identifier="org.jboss.osgi.http" startlevel="2" />
                      <module identifier="org.jboss.osgi.blueprint" startlevel="3" />
                      <module identifier="org.jboss.osgi.webapp" startlevel="3" />
                      <module identifier="org.jboss.osgi.xerces" startlevel="3" />
                  </modules>
              </subsystem>
              <subsystem xmlns="urn:jboss:domain:remoting:1.0" />
              <subsystem xmlns="urn:jboss:domain:resource-adapters:1.0">
                  <resource-adapters>
                      <resource-adapter>
                          <archive>
                              hsqldb
                          </archive>
                          <transaction-support>
                              LocalTransaction
                          </transaction-support>
                          <config-property name="min-pool-size">
                              5
                          </config-property>
                          <connection-definitions>
                              <connection-definition class-name="org.hsqldb.jdbcDriver"
                                  jndi-name="DefaultDS" pool-name="hsqldb-Pool" />
                          </connection-definitions>
                      </resource-adapter>
                  </resource-adapters>
              </subsystem>
              <subsystem xmlns="urn:jboss:domain:sar:1.0" />
              <subsystem xmlns="urn:jboss:domain:security:1.0">
                  <security-domains>
                      <security-domain name="other" cache-type="default">
                          <authentication>
                              <login-module code="Disabled" flag="required" />
                          </authentication>
                      </security-domain>
                  </security-domains>
              </subsystem>
              <subsystem xmlns="urn:jboss:domain:threads:1.0" />
              <subsystem xmlns="urn:jboss:domain:transactions:1.0">
                  <core-environment>
                      <process-id>
                          <uuid />
                      </process-id>
                  </core-environment>
                  <recovery-environment socket-binding="txn-recovery-environment"
                      status-socket-binding="txn-status-manager" />
                  <coordinator-environment default-timeout="300" />
                  <object-store />
              </subsystem>
              <subsystem xmlns="urn:jboss:domain:web:1.0"
                  default-virtual-server="default-host">
                  <connector name="http" protocol="HTTP/1.1" socket-binding="http"
                      scheme="http" />
                  <virtual-server name="default-host"
                      enable-welcome-root="true">
                      <alias name="localhost" />
                      <alias name="example.com" />
                  </virtual-server>
              </subsystem>
              <subsystem xmlns="urn:jboss:domain:weld:1.0" />
          </profile>
          <interfaces>
              <interface name="management">
                  <inet-address value="${jboss.bind.address.management:127.0.0.1}" />
              </interface>
              <interface name="public">
                  <inet-address value="${jboss.bind.address:127.0.0.1}" />
              </interface>
          </interfaces>
          <socket-binding-group name="standard-sockets"
              default-interface="public">
              <socket-binding name="http" port="8080" />
              <socket-binding name="https" port="8443" />
              <socket-binding name="jmx-connector-registry" port="1090"
                  interface="management" />
              <socket-binding name="jmx-connector-server" port="1091"
                  interface="management" />
              <socket-binding name="jndi" port="1099" />
              <socket-binding name="osgi-http" port="8090" interface="management" />
              <socket-binding name="remoting" port="4447" />
              <socket-binding name="txn-recovery-environment" port="4712" />
              <socket-binding name="txn-status-manager" port="4713" />
          </socket-binding-group>
      </server>