1 Reply Latest reply on Jan 3, 2012 10:56 PM by bingozzz bingozzz

    JBoss and Jackson

    Marten Lienen Newbie

      Hi,

      is it possible to use JBoss 7.0.2 with any other version of Jackson than 1.6.3? I tried to use 1.9.1 but it always threw a NoSuchMethodError, which was cause by conflicting versions of jackson-core and jackson-mapper.

       

      How can I make JBoss stopping from prefering its own version of jackson over the one that is in my war?

       

      Thanks in advance,

      CQQL

        • 1. Re: JBoss and Jackson
          bingozzz bingozzz Newbie

          fixed by this:

          add an jboss-deployment-structure.xml file to your project,for example,war/WEB-INFO

          the jboss-deployment-structure.xml 's content:

          <?xml version="1.0" encoding="UTF-8"?>

          <jboss-deployment-structure>

            <deployment>

              <exclusions>

                  <module name="org.codehaus.jackson.jackson-core-asl" />

                  <module name="org.codehaus.jackson.jackson-mapper-asl" />

                  <module name="org.codehaus.jackson.jackson-xc" />

                  <module name="org.codehaus.jackson.jackson-jaxrs" />

              </exclusions>

            </deployment>

           

          </jboss-deployment-structure>