3 Replies Latest reply on Nov 9, 2011 7:36 AM by Radoslav Husar

    Update Problems 1.1.0 to 1.1.3

    Jochen Riedlinger Newbie

      Hello,

       

      today I tried to upgrade from mod_cluster 1.1.0 to 1.1.3 and found several issues (my JBoss is an EAP 5.0.0) (old configuration was on OpenSUSE 11.2 new OpenSUSE 11.4):

       

      1.) The new "mod_cluster-jboss-beans.xml" seems to make problems. The only differences between the old and the new configurations are the "...modcluster..."-without "_" entries

      e.g.:

       

      ${jboss.mod_cluster.proxyList,jboss.modcluster.proxyList:}

      instead of

      ${jboss.mod_cluster.proxyList:}

       

      with the the new "mod_cluster-jboss-beans.xml" the mod_cluster-manager doesn't show any available node.

      If I put back the old 1.1.0 configuration (with the 1.1.3 jar) the webapplications are shown again in the mod_cluster-manger and work well (all, but the "/"-Root-Webapp; look at 2.)

       

       

      2.) I removed "ROOT" from the exclusion list, because our root-Web-application is clusterable.

      Unfortunately I can't access the root-context anymore if I use https.

       

      http://my-server                    -- this works

      https://my-server                   -- NOT working

       

      http://my-server/anyapplication     -- this works

      https://my-server/anyapplication    -- this works

       

       

      Do you have any hints how to resolve these issues?

       

       

      Tanks & best regards,

      Jochen