1 Reply Latest reply on Nov 9, 2011 3:30 AM by Alessio Soldano

    SPI Module Mismatch/Conflict with JBossWS Native 4.0.0BetaX on AS 7.0.2.Final

    Ken Bartholet Newbie

      I'm testing an upgrade of JBoss Containers from 4.2.3 to 7.0.2.  For various reasons, I'd like to continue using the Native JBossWS stack.

       

      I've downloaded jbossws-native-4.0.0.Beta1 from the SVN repository tag folder.  After building the binary distribution and installing into JBoss 7.0.2.final, the container startup throws as java.lang.NoSuchMethodError with the following stacktrace.  There appears to be a conflict/mismatch with the jbossws-spi.jar module in 4.0.0.Beta1 (version 2.0.0.Beta1)

      ______________

      11:15:29,691 INFO  [org.jboss.ws.common.management.AbstractServerConfig] (MSC service thread 1-2) JBoss Web Services - Native Server 4.0.0.Beta1

       

      11:15:29,113 ERROR [org.jboss.as.controller] (Controller Boot Thread) Operation ("add") failed - address: ([

          ("subsystem" => "webservices"),

          ("endpoint-config" => "Standard-Endpoint-Config")

      ]): java.lang.NoSuchMethodError: org.jboss.wsf.spi.management.ServerConfig.addEndpointConfig(Lorg/jboss/wsf/spi/metadata/config/EndpointConfig;)V

          at org.jboss.as.webservices.dmr.EndpointConfigAdd.performRuntime(EndpointConfigAdd.java:109)

          at org.jboss.as.controller.AbstractAddStepHandler$1.execute(AbstractAddStepHandler.java:50) [jboss-as-controller-7.0.2.Final.jar:7.0.2.Final]

          at org.jboss.as.controller.OperationContextImpl.executeStep(OperationContextImpl.java:353) [jboss-as-controller-7.0.2.Final.jar:7.0.2.Final]

          at org.jboss.as.controller.OperationContextImpl.doCompleteStep(OperationContextImpl.java:298) [jboss-as-controller-7.0.2.Final.jar:7.0.2.Final]

          at org.jboss.as.controller.OperationContextImpl.completeStep(OperationContextImpl.java:223) [jboss-as-controller-7.0.2.Final.jar:7.0.2.Final]

          at org.jboss.as.controller.AbstractAddStepHandler$1.execute(AbstractAddStepHandler.java:56) [jboss-as-controller-7.0.2.Final.jar:7.0.2.Final]

      ______________

       

       

      I then tried the same with both jbossws-native-4.0.0.Beta2 & Beta3 tags.  In both cases, after installing the stack, the console fails to deploy with a NoClassDefFoundError. There appears to be yet another conflict/mismatch with the jbossws-spi.jar module.  There exists a reference to the DeploymentType inner class, even though that class has been refactored to a standalone java class in the spi library/module referenced in these 2 stack versions.

      ______________

      11:39:21,400 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-6) MSC00001: Failed to start service jboss.deployment.unit."jbossws-console.war".INSTALL: org.jboss.msc.service.StartException in service jboss.deployment.unit."jbossws-console.war".INSTALL: Failed to process phase INSTALL of deployment "jbossws-console.war"

          at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:121) [jboss-as-server-7.0.2.Final.jar:7.0.2.Final]

          at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1824) [jboss-msc-1.0.1.GA.jar:1.0.1.GA]

          at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1759) [jboss-msc-1.0.1.GA.jar:1.0.1.GA]

          at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [:1.6.0_24]

          at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [:1.6.0_24]

          at java.lang.Thread.run(Thread.java:662) [:1.6.0_24]

      Caused by: java.lang.NoClassDefFoundError: org/jboss/wsf/spi/deployment/Deployment$DeploymentType

          at org.jboss.as.webservices.util.WSAttachmentKeys.<clinit>(WSAttachmentKeys.java:42)

          at org.jboss.as.webservices.deployers.WSTypeDeploymentProcessor.isJaxwsJseDeployment(WSTypeDeploymentProcessor.java:112)

          at org.jboss.as.webservices.deployers.WSTypeDeploymentProcessor.deploy(WSTypeDeploymentProcessor.java:44)

          at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:115) [jboss-as-server-7.0.2.Final.jar:7.0.2.Final]

          ... 5 more

      Caused by: java.lang.ClassNotFoundException: org.jboss.wsf.spi.deployment.Deployment$DeploymentType from [Module "org.jboss.as.webservices:main" from local module loader @192a848 (roots: C:\jboss-as-7.0.2.Final\modules)]

          at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:191) [jboss-modules.jar:1.0.2.GA]

          at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:361) [jboss-modules.jar:1.0.2.GA]

          at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:333) [jboss-modules.jar:1.0.2.GA]

          at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:310) [jboss-modules.jar:1.0.2.GA]

          at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:103) [jboss-modules.jar:1.0.2.GA]

          ... 9 more

      ______________

       

       

      Am I missing a step, or is the native stack simply not ready for JBoss AS 7?

      Any help would be appreciated.

       

      Thanks.

      -Ken