5 Replies Latest reply on Nov 11, 2011 8:22 AM by aldjinn

    mod-cluster-config ignored

    aldjinn Newbie

      Hi,

      I'm running 4 JBoss 7.0.2 instances in domain mode. Now I have two Apache2 Servers with mod_cluster and I want to connect 2/4 JBoss instances to each Apache2, not 4/4 to each.

       

      I've tried to adjust the

      <socket-binding name="modcluster" port="0" multicast-address="224.0.1.105" multicast-port="23364"/

      settings, but changes to the multicast-port are ignored.

       

      Then I tried to use mod-cluster-config in domain.xml, but also all settings made here are ignored.

       

      For example, with

       

      <subsystem xmlns="urn:jboss:domain:modcluster:1.0">

           <mod-cluster-config autoEnableContexts="false"/>

      </subsystem>

       

      still all deployed webapps are enabled by default.

       

      I've also tried to use

      <mod-cluster-config proxy-list="10.173.121.21:6667"/>

      and disabled ServerAdvertise in Apache2 (ServerAdvertise Off), but then no JBoss nodes are connected to Apache2.


      Any ideas?