5 Replies Latest reply on Nov 17, 2011 6:30 PM by Tomohisa igarashi

    Testing 0.3 CR1

    Keith Babo Master

      I posted an overview of 0.3 CR1 in the main forum:

       

      http://community.jboss.org/thread/174838

       

      As discussed on the call this morning, we need to test as many of the new features as we can.  Can everyone please grab the bits and test features this week?  It would be extra helpful if you could post in this thread what you have completed testing.  For example, if you decide to take the BPEL stuff out for a drive, post back into this thread with something like "tested BPEL component + quickstarts and everything worked for me".  Of course, if you run into issues, please file a JIRA and post that in the thread.  This will allows us to stay on the same page in terms of which features are getting attention and which are not.

       

      thanks,

      keith

        • 1. Re: Testing 0.3 CR1
          Gary Brown Master

          Hi Keith

           

          The 'direct link here' url on the post does not seem to be valid - getting a 404.

           

          Regards

          Gary

          • 2. Re: Testing 0.3 CR1
            Gary Brown Master

            Hi Keith

             

            "tested BPEL component + quickstarts and everything worked for me"

             

            The only thing I noticed was that if I build the BPEL quickstart when the server was running, then the tests failed as they were trying to start a server on the same port. Not sure if this is the same with some of the other components.

             

            Tried out the installer with AS7.1.0-Alpha2 and the BPEL quickstarts worked fine with this environment aswell.

             

            Also the top level readme is still referring to 0.1.

             

            Regards

            Gary

            • 3. Re: Testing 0.3 CR1
              Keith Babo Master

              Thanks, Gary. 

               

              The duplicate port stuff is annoying.  I'm thinking that we can use some work that Magesh did in 0.3 w/r/t socket binding to set the HTTP port differently in test and runtime.  Basically, this allows the default port:host setting to be managed outside the application configuration

               

              Good catch on the README.  Fixed:

               

              https://github.com/jboss-switchyard/release/commit/5bf441c945aaef827620f990aecd2d5e7f142e28

              • 4. Re: Testing 0.3 CR1
                Keith Babo Master


                Thanks for catching that.  Fixed.

                 

                 

                Gary Brown wrote:

                 

                Hi Keith

                 

                The 'direct link here' url on the post does not seem to be valid - getting a 404.

                 

                Regards

                Gary

                • 5. Re: Testing 0.3 CR1
                  Tomohisa igarashi Master

                  tested transform-xslt quickstart and found a trivial bug... https://issues.jboss.org/browse/SWITCHYARD-545

                   

                  and I have tried to deploy&run all of quickstarts. The results and note of that I have noticed is following.

                   

                  • bean-service, bpel-service, camel-binding, demos/orders, transform-jaxb: deploy&run OK
                  •  

                  • camel-jms-binding, hornetq-binding: deploy&run OK

                    NOTE: I needed to start AS7 as ./standalone.sh --server-config=standalone-preview.xml to activate HornetQ

                  •  

                  • camel-soap-proxy: deploy&run OK

                    NOTE: I needed to launch WebService on http://localhost:18001/ReverseService by myself like CamelSOAPProxyTest

                  •  

                  • camel-service: deploy&run OK

                    NOTE: I needed to add caller app to run - e.g. a Servlet and a bean service which is injected into Servlet and call JavaDSL service - JavaDSL service is not CDI bean service so couldn't be injected into Servlet directly

                  •  

                  • rules-interview, rules-interview-agent: deploy&run OK

                    NOTE: I needed to add caller app to run - e.g. a servlet and a bean service which is injected into Servlet and call Interview service - Interview service is not CDI bean service so couldn't be injected into Servlet directly

                  •  

                  • transform-json, transform-smooks: deploy&run OK

                    NOTE: I needed to add caller app to run - e.g. a Servlet. OrderService can be @Inject @Reference into Servlet directly, but JSON transformation doesn't happen in this case. In order to trigger this transformation, I have added a Java interface:

                        public interface TransformJsonCaller {

                            @OperationTypes(in="{urn:switchyard-quickstart:transform-json:1.0}order",

                                    out="{urn:switchyard-quickstart:transform-json:1.0}orderResponse")

                            public String submitOrder(String order);

                       }

                    and injected OrderService into Servlet as TransformJsonCaller:

                        @Inject @Reference("OrderService")

                        private TransformJsonCaller _service;

                         ...

                        String orderJson = "{"orderId":"1234","itemId":"BUTTER","quantity":"200"}";

                        String ackJson = _service.submitOrder(orderJson);

                    and then, JSON transformation is triggered since SwitchYard detects the I/O mismatch between TransformJsonCaller and OrderService. awesome!

                  •  

                  • demos/helpdesk: deploy OK, run SKIP...

                    NOTE: I couldn't catch how to run. caught java.lang.NullPointerException at org.jbpm.task.service.mina.MinaTaskClientConnector.write(MinaTaskClientConnector.java:118) so I may should have another step... maybe starting task server or something.

                  •  

                  • demos/webapp-deploy: deploy failed... is this only for pure servlet container and doesn't work with JBoss?