3 Replies Latest reply on Nov 29, 2011 11:32 AM by Lukáš Fryč

    RF 4.1 onbeforetoggle issue

    iabughosh Master

      Dears,

      i'am using rich:tree in two places, one in the main panel of my template, and the other one is in a popup, i'am using the onbeforetoggle event, it was running successfully since 4.0 to 4.1 M2, after M2 it is not functioning right, here is my tests :

      1- RF 4-M3, onbeforetoggle not firing in the main template & in the popup.

      2- RF 4-M4, main template is firing the event, popup is not firing.

      3- RF 4-CR1, same as M3.

       

      here is my .xhtml code :

      <rich:tree id="myTree"

                     var="node"

                     nodeType="#{node.type}"

                     toggleType="ajax"

                     selectionType="ajax">

             <rich:treeModelRecursiveAdaptor roots="#{bean.roots}"

                                                              nodes="#{node.folders}">

                     <rich:treeNode title="#{node.path}"

                                           type="folder"                                                                                                                

                                           onbeforetoggle="getSelectedPath('#{node.path}')"

                                           ondblclick="chooseFolder('#{node.ecmId}', '#{node.path}')"

                                           toggleListener="#{bean.treeToggleListener}">

       

                                    <h:outputText value="#{node.label}" />

                            </rich:treeNode>

                      </rich:treeModelRecursiveAdaptor>

                  </rich:tree>

       

      where getSelectedPath is a a4j:jsFunction.

       

      my enviroment :

      JDK 6.

      RF 4.1-x.

      JBoss 6.

      JSF 2.

       

      any hint will be great , thanks.