1 Reply Latest reply on Dec 1, 2011 7:56 AM by Kamesh Sampath

    jbpm5 Building from Source

    Kamesh Sampath Newbie

      when i try to build jbpm5 from source, am getting the folllowing missing dependnecy error , though i have all the maven repositories in my local Nexus.

       

      ....

      [INFO] jBPM Documentation ................................ FAILURE [9.792s]

      [INFO] jBPM distribution ................................. SKIPPED

      [INFO] ------------------------------------------------------------------------

      [INFO] BUILD FAILURE

      [INFO] ------------------------------------------------------------------------

      [INFO] Total time: 1:15.209s

      [INFO] Finished at: Wed Nov 30 14:07:37 IST 2011

      [INFO] Final Memory: 19M/261M

      [INFO] ------------------------------------------------------------------------

      [ERROR] Failed to execute goal org.jboss.maven.plugins:maven-jdocbook-plugin:2.2.3:resources (default-resources) on project jbpm-docs: Unexpected problem: Unable to locat

      e artifact [org.eclipse.core:resources:jar:3.3.1]: Failure to find org.eclipse.core:resources:jar:3.3.1 in http://localhost:8081/nexus/content/groups/public was cached in

      the local repository, resolution will not be reattempted until the update interval of nexus has elapsed or updates are forced

      [ERROR]

      [ERROR] Try downloading the file manually from the project website.

      [ERROR]

      [ERROR] Then, install it using the command:

      [ERROR] mvn install:install-file -DgroupId=org.eclipse.core -DartifactId=resources -Dversion=3.3.1 -Dpackaging=jar -Dfile=/path/to/file

      [ERROR]

      [ERROR] Alternatively, if you host your own repository you can deploy the file there:

      [ERROR] mvn deploy:deploy-file -DgroupId=org.eclipse.core -DartifactId=resources -Dversion=3.3.1 -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]

      [ERROR]

      [ERROR] Path to dependency:

      [ERROR] 1) org.jbpm:jbpm-docs:jdocbook:5.1.1.Final

      [ERROR] 2) org.eclipse.wst.css:core:jar:1.1.101-v200705302225

      [ERROR] 3) org.eclipse.wst.xml:core:jar:1.1.201-v200709201331

      [ERROR]

      [ERROR]

      [ERROR] org.eclipse.core:resources:jar:3.3.1

      [ERROR]

      [ERROR] from the specified remote repositories:

      [ERROR] nexus (http://localhost:8081/nexus/content/groups/public, releases=true, snapshots=true)

      ...