4 Replies Latest reply on Dec 2, 2011 1:41 AM by Nicklas Karlsson

    Data Source creation using CLI in 7.1.0.Beta1 not working

    Ramesh Reddy Master

      Hi,

       

      I tried creating a data source using CLI in the 7.1.0.Beta1 using

       

      [standalone@localhost:9999 /] 
      [standalone@localhost:9999 /] deploy /home/rareddy/testing/jdbcdrivers/modules/com/mysql/main/mysql-connector-java-5.1.5.jar   
      'mysql-connector-java-5.1.5.jar' deployed successfully.
      [standalone@localhost:9999 /] /subsystem=datasources/data-source=mysql-ds:add(jndi-name=java:/mysql-ds, pool-name=mysql-ds, driver-name=mysql-connector-java-5.1.5.jar, connection-url=jdbc:mysql://localhost:3306/txns,user-name=rareddy, password=mm)
      {"outcome" => "success"}
      

       

      This creates a datasource related configuration in the standalone.xml file, however it is not starting service for data source, nor binding to the JNDI name. I know this worked before in earlier versions. Is this a regression or bug?

       

      However, if you restart the server, it will start the datasource as it is configured now in the standalone.xml

       

      Thanks

       

      Ramesh..