0 Replies Latest reply on Dec 7, 2011 6:40 AM by Venkataramana Reddy

    problem with rich:select with Ajax after more than 2 times selection

    Venkataramana Reddy Newbie


      Below is the exact senerio where the problem exists.... This can be identified only when you try to implement as mentioned below....

       

      Consider 3 rich:select items.... in which on selection of first 2 ... the 3rd will be displayed....

       

      Consider the values for 1st drop-down as (ALL,A,B,C)

      Consider the values for 2st drop-down as (ALL,X,Y,Z)

       

       

      <rich:select id="productLine" defaultLabel="ALL"

                                                        value="#{....}">

                                                        <a4j:ajax render="members" event="selectitem" />

                                                        <f:selectItems value="#{.......}" />

                                              </rich:select>

       

      <rich:select defaultLabel="ALL"

                                                        value="#{.....}"

                                                        id="location">

                                                        <a4j:ajax render="members" event="selectitem" />

                                                        <f:selectItems value="#{.................}" />

                                              </rich:select>

       

      <h:selectManyListbox id="members" size="6"

                                                        value="#{..................}">

                                                        <f:selectItems value="#{....................}" />

                                              </h:selectManyListbox>

       

      Exact Problem :  Initially the first 2 drop-down values are ALL & ALL...

      I have selected the First Drop-down value as "A" ----- Rendering Works fine

      I have selected the Second Drop-down value as "X" ----- Rendering Works fine

      I have selected the First Drop-down value as "B" ----- Rendering Works fine

      I have selected the Second Drop-down value as "Y" ----- Rendering Works fine

      I have selected the Second Drop-down value as "X" ----- Problem occured (Rendered doesn't happened.)

      I have selected the First Drop-down value as "A" ----- Rendering Works fine

      I have selected the First Drop-down value as "B" ----- Problem occured (Rendered doesn't happened.)



      This is the problem where i have seen in some posts.. where the people doesn't explained clearly to the Experts in the community....

       

      Can any one try to give the solution for this............... Is this the framework problem?