3 Replies Latest reply on Dec 14, 2011 9:23 AM by Chris Melas

    Table data loss after re-deploy application




      May be this question already discussed but i am not able to find that discussion and it is little very basic about hibernate.Can someone help me to understand the below?


      Actully in my persistance.xml i have two JPA unit named


      JBPM Version 5.0


      org.jbpm.task :

                  <property name="hibernate.connection.autocommit" value="false" />

                  <property name="hibernate.max_fetch_depth" value="3"/>

                  <property name="hibernate.hbm2ddl.auto" value="create" />

                  <property name="hibernate.show_sql" value="true" />


      org.jbpm.persistence.jpa  :
                  <property name="hibernate.connection.autocommit" value="false"/>
                  <property name="hibernate.max_fetch_depth" value="3"/>
                  <property name="hibernate.hbm2ddl.auto" value="update" />
                  <property name="hibernate.show_sql" value="true" />


      My question here is, i am able to deploy the JBPM application in Oracle environment and all looks good.When i redeploy (after some code modification)it is deleteting my tables and recreating tables again.because of that i lost my old data in JBPM tables(create option will delete and recreate the tables again).

      i tried changing the property hibernate.hbm2ddl.auto=update in both unit but i am getting constraint violation error(example : "User" table is not allowing to inst erthe same record again.because it was alredy there in my first run).


      Can someone clarify this how to achive this,

      1.The already inserted records should not affect

      2.Dont create table if exist already in table

      3.Also it would be great if get executable table script to deploy it.


      Can anyone share the exact  configuration for the above?Let me know if my question is not clear here.


      or if this is already discussed can you share those link??

      Thanks in advance.