1 Reply Latest reply on Dec 15, 2011 11:23 AM by Aslak Knutsen

    Issues with JBoss 7.1.0.Beta1 and Arquillian 1.0.0.Alpha5

    Richard Allred Newbie

      So I'm trying to migrate from JBoss AS 7.0.0 to 7.1.0 and I can't seem to get Arquillian to work at all. Before the migration we were using Arquillian 1.0.0.CR1.

       

       

      Here is the dependency my current pom.xml

      <dependency>
                  <groupId>org.jboss.arquillian</groupId>
                  <artifactId>arquillian-junit</artifactId>
                  <version>1.0.0.Alpha5</version>
                  <scope>test</scope>
      </dependency>
      

       

       

      The strange part is that when I run the test suite with maven, arquillian bombs out immediately without ever attempting to communicate with JBoss.  The error is as follows...

      Tests in error:
        initializationError(com.advancestores.storechannel.catalog.business.EPCApplicationListManagerBPContainerTest): org/jboss/shrinkwrap/descriptor/impl/base/NodeProviderImplBase
        initializationError(com.advancestores.storechannel.catalog.business.ProductLookUpBPContainerTest): Arquillian has previously been attempted initialized, but failed. See previous exceptions for cause.
      

      and I get that error message exactly for all of my tests.  I'm not sure I have the ability to "see previous exception for cause" which makes this extra frustrating since I have no idea what could be the cause.  I have tried cleaning out my JBoss server and restarting my computer, to no avail.  I even get this error when I have no JBoss instance running, so it's clearly not even trying to initialize arqullian in the container at all.

       

      Is there something I need to do to 'reset' arquillian.  This seems like a pretty generic error, and it doesn't make sense to me as to why it wouldn't attempt to reinitialize Arquillian ever...