0 Replies Latest reply on Dec 14, 2011 11:17 PM by vj29

    JBoss 5 server startup issues

    vj29 Newbie

      Hi,

      Am a newbie to jboss and i have installed jboss soa- p server and trying to configure juddi .

      Below are the files that i have changed to setup juddi .

       

       

      1.jboss-as\server\default\deployers\esb.deployer\jbossesb-properties.xml  :

       

       

      <properties name="registry">

               <property name="org.jboss.soa.esb.registry.queryManagerURI" value="org.apache.juddi.registry.local.InquiryService#inquire"/>

               <property name="org.jboss.soa.esb.registry.lifeCycleManagerURI" value="org.apache.juddi.registry.local.PublishService#publish"/>

           <property name="org.jboss.soa.esb.registry.securityManagerURI" value="org.apache.juddi.registry.local.SecurityService#secure"/>

               <property name="org.jboss.soa.esb.registry.implementationClass" value="org.jboss.internal.soa.esb.services.registry.JAXRRegistryImpl"/>

               <property name="org.jboss.soa.esb.registry.factoryClass" value="org.apache.ws.scout.registry.ConnectionFactoryImpl"/>

               <property name="org.jboss.soa.esb.registry.user" value="root"/>

               <property name="org.jboss.soa.esb.registry.password" value="root"/>

               <!-- the following parameter is scout specific to set the type of communication between scout and the UDDI (embedded, rmi, soap) -->

               <property name="org.jboss.soa.esb.scout.proxy.transportClass" value="org.apache.ws.scout.transport.LocalTransport"/>

           <!-- <property name="org.jboss.soa.esb.scout.proxy.uddiVersion" value="3.0"/>

           <property name="org.jboss.soa.esb.scout.proxy.uddiNameSpace" value="urn:uddi-org:api_v3"/> -->

       

       

      2.jboss-as\server\default\deploy\jbossesb.sar\ebs.juddi.client.xml : Uncomented VM transport and commented out the RMITransport block

       

       

      3.\jboss-as\server\default\deploy\jbossesb-registry.sar\juddi_config\META-INF\persistence.xml : updated  props for mysql dialect.

      <properties>

              <property name="hibernate.archive.autodetection" value="class"/>

              <property name="hibernate.show_sql" value="false"/>

            <property name="hibernate.dialect" value="org.hibernate.dialect.MySQLDialect" />

          </properties>

      4.jboss-as\server\default\deploy\jbossesb-registry.sar\esb.juddi.xml :Updated for mysql db ref

      <entry key=”juddi.sqlFiles”>juddi-sql/mysql/create_database.sql,juddi-sql/mysql/import.sql</entry>

      (

      5.\jboss-as\server\default\deploy\juddiv3.war\WEB-INF\classes :Added  file juddiv3.properties(Attached for ref)

      6.\jboss-as\server\default\deploy\juddiv3.war\WEB-INF\: Added juddi-user.xml

      <?xml version="1.0" encoding="UTF-8"?>

      <juddi-users>

        <user userid="sviens" password="password" />

        <user userid="juddi" password="password" />

          </juddi-users>

      7jbosss-as\server\default\deploy\jbossesb.esb\jbossesb.service.xml :updated below settings for mysql

      <?xml version="1.0" encoding="UTF-8"?>

       

       

      <server>

         <mbean code="org.jboss.internal.soa.esb.dependencies.DatabaseInitializer"

             name="jboss.esb:service=MessageStoreDatabaseInitializer">

            <attribute name="Datasource">java:/JBossESBDS</attribute>

            <attribute name="ExistsSql">select count(*) from message</attribute>

            <attribute name="SqlFiles">

               message-store-sql/mysql/create_database.sql

            </attribute>

            <depends>jboss.jca:service=DataSourceBinding,name=JBossESBDS</depends>

         </mbean>

      </server>

      8.\jboss-as\server\default\deploy\jbossesb-registry.sar : update juddi-ds.xml

      <datasources>

         <local-tx-datasource>

               <jndi-name>juddiDB</jndi-name>

               <connection-url>jdbc:mysql://localhost:3306/juddi</connection-url> <!-- port is 3306 -->

               <driver-class>com.mysql.jdbc.Driver</driver-class>

               <user-name>root</user-name>

               <password>password</password>

         </local-tx-datasource>

      </datasources>

      9. \jboss-as\server\default\deploy\jbossesb-registry.sar :  Added new prop to  esb.juddi.xml

      <entry key="juddi.sqlFiles">juddi-sql/mysql/import.sql</entry>

       

       

      10.Updated classpath to refre 

      mysql-connector-java-5.0.4-bin.jar

      jbossesb-properties.xml;

      esb.juddi.xml

       

       

      11.Copied mysql-connector-java-5.0.4-bin.jar to boss-soa-p-5\jboss-as\server\default\lib

       

       

      Started the jboss server and attached is complete log file but belwo are the errors.

       

       

      boot.log

      org.jboss.deployers.spi.DeploymentException: Error deploying: file:/C:/jboss-soa-p-5/jboss-as/server/default/conf/bootstrap/vfs.xml

           at org.jboss.deployers.spi.DeploymentException.rethrowAsDeploymentException(DeploymentException.java:49)

           at org.jboss.deployers.vfs.deployer.kernel.BeanMetaDataFactoryVisitor.deploy(BeanMetaDataFactoryVisitor.java:136)

           at org.jboss.system.server.profileservice.ProfileServiceBootstrap.initBootstrapMDs(ProfileServiceBootstrap.java:426)

           at org.jboss.system.server.profileservice.ProfileServiceBootstrap.start(ProfileServiceBootstrap.java:242)

           at org.jboss.bootstrap.AbstractServerImpl.start(AbstractServerImpl.java:461)

           at org.jboss.Main.boot(Main.java:221)

           at org.jboss.Main$1.run(Main.java:556)

           at java.lang.Thread.run(Thread.java:662)

      Caused by: java.lang.IllegalStateException: ClassLoader has not been set

           at org.jboss.deployers.structure.spi.helpers.AbstractDeploymentUnit.getClassLoader(AbstractDeploymentUnit.java:159)

           at org.jboss.deployers.vfs.deployer.kernel.BeanMetaDataFactoryVisitor.addBeanComponent(BeanMetaDataFactoryVisitor.java:60)

           at org.jboss.deployers.vfs.deployer.kernel.BeanMetaDataFactoryVisitor.deploy(BeanMetaDataFactoryVisitor.java:126)

           ... 6 more

       

       

       

       

       

       

      org.jboss.deployers.spi.DeploymentException: Error deploying: file:/C:/jboss-soa-p-5/jboss-as/server/default/conf/bootstrap/logging.xml

           at org.jboss.deployers.spi.DeploymentException.rethrowAsDeploymentException(DeploymentException.java:49)

           at org.jboss.deployers.vfs.deployer.kernel.BeanMetaDataFactoryVisitor.deploy(BeanMetaDataFactoryVisitor.java:136)

           at org.jboss.system.server.profileservice.ProfileServiceBootstrap.initBootstrapMDs(ProfileServiceBootstrap.java:426)

           at org.jboss.system.server.profileservice.ProfileServiceBootstrap.start(ProfileServiceBootstrap.java:242)

           at org.jboss.bootstrap.AbstractServerImpl.start(AbstractServerImpl.java:461)

           at org.jboss.Main.boot(Main.java:221)

           at org.jboss.Main$1.run(Main.java:556)

           at java.lang.Thread.run(Thread.java:662)

      Caused by: java.lang.IllegalStateException: ClassLoader has not been set

           at org.jboss.deployers.structure.spi.helpers.AbstractDeploymentUnit.getClassLoader(AbstractDeploymentUnit.java:159)

           at org.jboss.deployers.vfs.deployer.kernel.BeanMetaDataFactoryVisitor.addBeanComponent(BeanMetaDataFactoryVisitor.java:60)

           at org.jboss.deployers.vfs.deployer.kernel.BeanMetaDataFactoryVisitor.deploy(BeanMetaDataFactoryVisitor.java:126)

           ... 6 more

       

       

       

       

      server.log

       

       

      ERROR [ProfileServiceBootstrap] Failed to load profile: Summary of incomplete deployments (SEE PREVIOUS ERRORS FOR DETAILS):

       

       

       

       

      DEPLOYMENTS MISSING DEPENDENCIES:

        Deployment "BPELEngine" is missing the following dependencies:

          Dependency "jboss.esb:service=JuddiClient" (should be in state "Create", but is actually in state "Configured")

        Deployment "jboss.esb.vfsfile:/C://jboss-soa-p-5/jboss-as/server/default/deploy/jbossesb.esb/" is missing the following dependencies:

          Dependency "<UNKNOWN jboss.esb.vfsfile:/C:/jboss-soa-p-5/jboss-as/server/default/deploy/jbossesb.esb/>" (should be in state "Installed", but is actually in state "** UNRESOLVED Demands 'jboss.esb:service=JuddiClient' **")

        Deployment "jboss.esb.vfsfile:/C:/jboss-soa-p-5/jboss-as/server/default/deploy/jbpm.esb/" is missing the following dependencies:

          Dependency "<UNKNOWN jboss.esb.vfsfile:/C:/jboss-soa-p-5/jboss-as/server/default/deploy/jbpm.esb/>" (should be in state "Installed", but is actually in state "** UNRESOLVED Demands 'jboss.esb:deployment=jbossesb.esb' **")

        Deployment "jboss.esb.vfsfile:/C:/jboss-soa-p-5/jboss-as/server/default/deploy/jbrules.esb/" is missing the following dependencies:

          Dependency "<UNKNOWN jboss.esb.vfsfile:/C:/jboss-soa-p-5/jboss-as/server/default/deploy/jbrules.esb/>" (should be in state "Installed", but is actually in state "** UNRESOLVED Demands 'jboss.esb:deployment=jbossesb.esb' **")

        Deployment "jboss.esb.vfsfile:/C:/jboss-soa-p-5/jboss-as/server/default/deploy/riftsaw-esb.esb/" is missing the following dependencies:

          Dependency "<UNKNOWN jboss.esb.vfsfile:/c:/jboss-soa-p-5/jboss-as/server/default/deploy/riftsaw-esb.esb/>" (should be in state "Installed", but is actually in state "** UNRESOLVED Demands 'jboss.bpel:service=BPELEngine' **")

          Dependency "<UNKNOWN jboss.esb.vfsfile:/C:/jboss-soa-p-5/jboss-as/server/default/deploy/riftsaw-esb.esb/>" (should be in state "Installed", but is actually in state "** UNRESOLVED Demands 'jboss.esb:deployment=jbossesb.esb' **")

        Deployment "jboss.esb.vfsfile:/C:/jboss-soa-p-5/jboss-as/server/default/deploy/slsb.esb/" is missing the following dependencies:

          Dependency "<UNKNOWN jboss.esb.vfsfile:/C:/jboss-soa-p-5/jboss-as/server/default/deploy/slsb.esb/>" (should be in state "Installed", but is actually in state "** UNRESOLVED Demands 'jboss.esb:deployment=jbossesb.esb' **")

        Deployment "jboss.esb.vfsfile:/C:/jboss-soa-p-5/jboss-as/server/default/deploy/smooks.esb/" is missing the following dependencies:

          Dependency "<UNKNOWN jboss.esb.vfsfile:/C:/jboss-soa-p-5/jboss-as/server/default/deploy/smooks.esb/>" (should be in state "Installed", but is actually in state "** UNRESOLVED Demands 'jboss.esb:deployment=jbossesb.esb' **")

        Deployment "jboss.esb.vfsfile:/C:/jboss-soa-p-5/jboss-as/server/default/deploy/soap.esb/" is missing the following dependencies:

          Dependency "<UNKNOWN jboss.esb.vfsfile:/C:/jboss-soa-p-5/jboss-as/server/default/deploy/soap.esb/>" (should be in state "Installed", but is actually in state "** UNRESOLVED Demands 'jboss.esb:deployment=jbossesb.esb' **")

        Deployment "jboss.esb.vfsfile:/C:/jboss-soa-p-5/jboss-as/server/default/deploy/spring.esb/" is missing the following dependencies:

          Dependency "<UNKNOWN jboss.esb.vfsfile:/C:/jboss-soa-p-5/jboss-as/server/default/deploy/spring.esb/>" (should be in state "Installed", but is actually in state "** UNRESOLVED Demands 'jboss.esb:deployment=jbossesb.esb' **")

        Deployment "jboss.esb:service=JuddiClient" is missing the following dependencies:

          Dependency "jboss.esb:service=JuddiRMI" (should be in state "Create", but is actually in state "Configured")

        Deployment "jboss.esb:service=JuddiRMI" is missing the following dependencies:

          Dependency "jboss.esb:service=JUDDIDatabaseInitializer" (should be in state "Create", but is actually in state "** NOT FOUND Depends on 'jboss.esb:service=JUDDIDatabaseInitializer' **")

        Deployment "jboss.web.deployment:war=/juddiv3" is missing the following dependencies:

          Dependency "jboss.esb:service=JuddiRMI" (should be in state "Create", but is actually in state "Configured")

       

       

       

       

      DEPLOYMENTS IN ERROR:

        Deployment "<UNKNOWN jboss.esb.vfsfile:/C:/jboss-soa-p-5/jboss-as/server/default/deploy/soap.esb/>" is in error due to the following reason(s): ** UNRESOLVED Demands 'jboss.esb:deployment=jbossesb.esb' **

        Deployment "<UNKNOWN jboss.esb.vfsfile:/C:/jboss-soa-p-5/jboss-as/server/default/deploy/jbrules.esb/>" is in error due to the following reason(s): ** UNRESOLVED Demands 'jboss.esb:deployment=jbossesb.esb' **

        Deployment "jboss.esb:service=JUDDIDatabaseInitializer" is in error due to the following reason(s): ** NOT FOUND Depends on 'jboss.esb:service=JUDDIDatabaseInitializer' **

        Deployment "<UNKNOWN jboss.esb.vfsfile:/C:/jboss-soa-p-5/jboss-as/server/default/deploy/smooks.esb/>" is in error due to the following reason(s): ** UNRESOLVED Demands 'jboss.esb:deployment=jbossesb.esb' **

        Deployment "<UNKNOWN jboss.esb.vfsfile:/C:/jboss-soa-p-5/jboss-as/server/default/deploy/riftsaw-esb.esb/>" is in error due to the following reason(s): ** UNRESOLVED Demands 'jboss.bpel:service=BPELEngine' **, ** UNRESOLVED Demands 'jboss.esb:deployment=jbossesb.esb' **

        Deployment "<UNKNOWN jboss.esb.vfsfile:/C:/jboss-soa-p-5/jboss-as/server/default/deploy/jbossesb.esb/>" is in error due to the following reason(s): ** UNRESOLVED Demands 'jboss.esb:service=JuddiClient' **

        Deployment "<UNKNOWN jboss.esb.vfsfile:/C:/jboss-soa-p-5/jboss-as/server/default/deploy/spring.esb/>" is in error due to the following reason(s): ** UNRESOLVED Demands 'jboss.esb:deployment=jbossesb.esb' **

        Deployment "<UNKNOWN jboss.esb.vfsfile:/C:/jboss-soa-p-5/jboss-as/server/default/deploy/jbpm.esb/>" is in error due to the following reason(s): ** UNRESOLVED Demands 'jboss.esb:deployment=jbossesb.esb' **

        Deployment "<UNKNOWN jboss.esb.vfsfile:/C:/jboss-soa-p-5/jboss-as/server/default/deploy/slsb.esb/>" is in error due to the following reason(s): ** UNRESOLVED Demands 'jboss.esb:deployment=jbossesb.esb' **

       

       

       

       

      ALSO, in server log i see "Using dialect: org.hibernate.dialect.HSQLDialect",dis i miss changing anyother settings to connect to mysqldb.

       

       

      Please let me know,where i went wrong and  what props i need to set to get my server up and running with juddi configured.

       

       

      Thanks

       

       

      VJ