5 Replies Latest reply on Apr 1, 2010 4:23 AM by Ilya Shaikovsky

    rich:effect bug?

    Andrew Naish Newbie

      Hi I think I have found a bug with respect to the rich:effect tag.

      The following code looks right to me, however it does not seem to work using a safari based browser (Chrome/Safari)



      ..... div content ......



      <rich:effect name="hideDiv" for="contentDiv" type="Fade" />
      <rich:effect name="showDiv" for="contentDiv" type="Appear" />


      This is an example given on the rich faces website

      see the Variants section here:

      http://livedemo.exadel.com/richfaces-demo/richfaces/effect.jsf?c=effect&tab=usage

      Anyone know where I can submit this for review by the richfaces team?

        • 1. Re: rich:effect bug?
          Andrew Naish Newbie

          Sorry the code is this:

          
          <div id="test">
          <div id="contentDiv">
          ..... div content ......
          </div>
          <input type="button" onclick="hideDiv()" value="Hide" />
          <input type="button" onclick="showDiv()" value="Show" />
          <rich:effect name="hideDiv" for="contentDiv" type="Fade" />
          <rich:effect name="showDiv" for="contentDiv" type="Appear" />
          </div>
          
          


          • 2. Re: rich:effect bug?
            Ilya Shaikovsky Master

            For me livedemo sample wroks fine..

            and b.t.w. we just wrapping scriptaculous effects in the effect component so if it has known problems related to specified browsers we could only rely on original script fixes and incorporating updated ones in RF.

            • 3. Re: rich:effect bug?
              Andrew Naish Newbie

               

              "ilya_shaikovsky" wrote:
              For me livedemo sample wroks fine..

              and b.t.w. we just wrapping scriptaculous effects in the effect component so if it has known problems related to specified browsers we could only rely on original script fixes and incorporating updated ones in RF.


              Well, I have tried it on a few different instances of chrome and safari and I still can't get it working. It's definatley something to do with the safari engine - it works fine on IE & Firefox.

              Here is the whole xhtml:

              <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
               "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
              
              <ui:composition xmlns="http://www.w3.org/1999/xhtml"
               xmlns:ui="http://java.sun.com/jsf/facelets"
               xmlns:rich="http://richfaces.org/rich"
               >
              
               <div id="test">
               <div id="contentDiv">
               ..... div content ......
               </div>
               <input type="button" onclick="hideDiv()" value="Hide" />
               <input type="button" onclick="showDiv()" value="Show" />
              
               <rich:effect name="hideDiv" for="contentDiv" type="Fade" />
               <rich:effect name="showDiv" for="contentDiv" type="Appear" />
               </div>
              
              </ui:composition>
              
              


              • 4. Re: rich:effect bug?
                bb bb Master

                I have the same problem.

                 

                But it appears only when the name attribute was defined, when I use the event property(like the demo page) no errors.

                 

                I think it's a bug.