1 Reply Latest reply: Jan 4, 2012 9:40 AM by Alessio Soldano RSS

    CXF webservices not deployed

    miragpl Newbie

      Hi all,

       

      I'm migrating web application (packaged as a war) from jboss 4 to jboss 6 and cannot make CXF webservices run properly. I use cxf 2.3.1-patch-01 (the one bundled with jboss 6.1).

       

      During deployment I got following log:

       

      2011-12-27 14:33:27,895 INFO  [org.apache.catalina.core.ContainerBase.[jboss.web].[localhost].[/webApp]] (Thread-2) Initializing Spring root WebApplicationContext

      2011-12-27 14:33:29,020 INFO  [org.apache.cxf.service.factory.ReflectionServiceFactoryBean] (Thread-2) Creating Service {http://org.test/webApp}webApp from class org.test.webApp.webservice.webAppService

      2011-12-27 14:33:30,833 INFO  [org.apache.cxf.endpoint.ServerImpl] (Thread-2) Setting the server's publish address to be /webAppService/ENDPOINT1

      2011-12-27 14:33:30,833 INFO  [org.apache.cxf.endpoint.ServerImpl] (Thread-2) Setting the server's publish address to be /webAppService/ENDPOINT1

      2011-12-27 14:33:30,895 INFO  [org.apache.cxf.service.factory.ReflectionServiceFactoryBean] (Thread-2) Creating Service {http://org.test/webApp}webApp from class org.test.webApp.webservice.webAppService

      2011-12-27 14:33:30,973 INFO  [org.apache.cxf.endpoint.ServerImpl] (Thread-2) Setting the server's publish address to be /webAppService/ENDPOINT2

      2011-12-27 14:33:30,989 INFO  [org.apache.cxf.service.factory.ReflectionServiceFactoryBean] (Thread-2) Creating Service {http://org.test/webApp}webApp from class org.test.webApp.webservice.webAppService

      2011-12-27 14:33:31,083 INFO  [org.apache.cxf.endpoint.ServerImpl] (Thread-2) Setting the server's publish address to be /webAppService/ENDPOINT3

      2011-12-27 14:33:31,083 INFO  [org.apache.cxf.transport.servlet.AbstractCXFServlet] (Thread-2) Load the bus with application context

      2011-12-27 14:33:31,083 INFO  [org.apache.cxf.bus.spring.BusApplicationContext] (Thread-2) Refreshing org.apache.cxf.bus.spring.BusApplicationContext@70cfff: display name [org.apache.cxf.bus.spring.BusApplicationContext@70cfff]; startup date [Tue Dec 27 14:33:31 CET 2011]; parent: org.springframework.web.context.support.XmlWebApplicationContext@96f8ea

      2011-12-27 14:33:31,083 INFO  [org.apache.cxf.bus.spring.BusApplicationContext] (Thread-2) Bean factory for application context [org.apache.cxf.bus.spring.BusApplicationContext@70cfff]: org.springframework.beans.factory.support.DefaultListableBeanFactory@1131db6

      2011-12-27 14:33:31,098 INFO  [org.apache.cxf.transport.servlet.AbstractCXFServlet] (Thread-2) Servlet transport factory already registered

       

       

      Basically I don't receive any errors/warnings during deployemnt but the webservices are not deployed at all. The list of webservices in webservice console is empty.

       

      My web.xml:

       

      <?xml version="1.0" encoding="UTF-8"?>

      <web-app version="2.5"

               xmlns="http://java.sun.com/xml/ns/javaee"

               xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"

               xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd">

       

       

                <context-param>

                          <param-name>contextConfigLocation</param-name>

                    <param-value>

                                    WEB-INF/applicationContext.xml

                          </param-value>

                </context-param>

       

                <listener>

                          <listener-class>org.springframework.web.context.ContextLoaderListener</listener-class>

                </listener>

       

                <servlet>

                          <servlet-name>CXFServlet</servlet-name>

                          <servlet-class>

                                    org.apache.cxf.transport.servlet.CXFServlet

                          </servlet-class>

                          <load-on-startup>1</load-on-startup>

                </servlet>

       

       

                <servlet-mapping>

                          <servlet-name>CXFServlet</servlet-name>

                          <url-pattern>/*</url-pattern>

                </servlet-mapping>

      </web-app>

       

      I would appreciate any hint. Thanks in advance!