1 Reply Latest reply on Jan 8, 2012 5:44 AM by Radoslav Husar

    Jboss5.1 session replication on two virtual machine not success but on one machine replication well

    ylq2250 kun Newbie

      the two virtual machine can ping each other and the IP address are 172.16.1.151 and 172.16.1.153,both have the window OS.

       

      when i deploy two Jboss5.1 on one virtual machine(153)  and start them with the flow commands:

      enter one of the jboss5.1 JBOSSHOME\lib and execute

      run.bat -c all -b 0.0.0.0 -Djboss.jgroups.tcp.tcp_port=7600 -Djgroups.bind_addr=172.16.1.153 -Djboss.default.jgroups.stack=tcp -Djgroups.tcpping.initial_hosts=172.16.1.153[7600],172.16.1.153[7602]

      enter another and execute

      run.bat -c all -b 0.0.0.0 -Djboss.jgroups.tcp.tcp_port=7602 -Djgroups.bind_addr=172.16.1.153 -Djboss.default.jgroups.stack=tcp -Djgroups.tcpping.initial_hosts=172.16.1.153[7600],172.16.1.153[7602]

       

      the two jboss start successfully,and the session can replication.

       

      but when i put one of the jboss on virtualMachine(151) and execute the follow command:

       

      run.bat -c all -b 0.0.0.0 -Djboss.jgroups.tcp.tcp_port=7600 -Djgroups.bind_addr=172.16.1.151 -Djboss.default.jgroups.stack=tcp -Djgroups.tcpping.initial_hosts=172.16.1.151[7600],172.16.1.153[7602]

       

      the other jboss on the virtualMachine(153) starts with the follow command:

      run.bat -c all -b 0.0.0.0 -Djboss.jgroups.tcp.tcp_port=7602 -Djgroups.bind_addr=172.16.1.153 -Djboss.default.jgroups.stack=tcp -Djgroups.tcpping.initial_hosts=172.16.1.151[7600],172.16.1.153[7602]

       

      the two jboss start successfully with clustering,but the session can not replication,can anyobdy tell me what wrong with my situation? if i ignore some importent confige steps?

       

      I don't need loadbalance  just want to use the session repllication between the two jboss AS.