4 Replies Latest reply on Feb 2, 2012 9:16 AM by Thomas Diesler

    Grails on JBoss AS 7.0.2 Final

    Gary Quinn Newbie

      I am trying to deploy a grails war on Jboss 7.0.2 Final with no success. The same war deployed fine on Tomcat 7.

       

      I created a clean grails app: grails create-app GrailApp

      Created the war: grails war

       

      and tried to deploy it on jboss.

       

      I get the following error:

       

      09:37:31,361 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-6) Starting deployment of "GrailApp-0.1.war"

      09:37:33,554 WARN  [org.jboss.as.server.deployment.service-loader] (MSC service thread 1-5) Encountered invalid class name "org.xmlpull.mxp1.MXParser,org.xmlpull.mxp1_serializer.MXSerializer" for service type "org.xmlpull.v1.XmlPullParserFactory"

      09:37:33,557 INFO  [org.jboss.as.jpa] (MSC service thread 1-6) added javax.persistence.api dependency to GrailApp-0.1.war

      09:37:33,567 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-8) MSC00001: Failed to start service jboss.deployment.unit."GrailApp-0.1.war".POST_MODULE: org.jboss.msc.service.StartException in service jboss.deployment.unit."GrailApp-0.1.war".POST_MODULE: Failed to process phase POST_MODULE of deployment "GrailApp-0.1.war"

                at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:121) [jboss-as-server-7.0.2.Final.jar:7.0.2.Final]

                at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1824) [jboss-msc-1.0.1.GA.jar:1.0.1.GA]

                at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1759) [jboss-msc-1.0.1.GA.jar:1.0.1.GA]

                at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [:1.6.0_30]

                at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [:1.6.0_30]

                at java.lang.Thread.run(Thread.java:662) [:1.6.0_30]

      Caused by: java.lang.NullPointerException

                at org.jboss.as.ejb3.deployment.processors.BusinessViewAnnotationProcessor.deploy(BusinessViewAnnotationProcessor.java:78)

                at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:115) [jboss-as-server-7.0.2.Final.jar:7.0.2.Final]

                ... 5 more

       

       

      09:37:33,570 INFO  [org.jboss.as.server.controller] (HttpManagementService-threads - 10) Deployment of "GrailApp-0.1.war" was rolled back with failure message {"Failed services" => {"jboss.deployment.unit.\"GrailApp-0.1.war\".POST_MODULE" => "org.jboss.msc.service.StartException in service jboss.deployment.unit.\"GrailApp-0.1.war\".POST_MODULE: Failed to process phase POST_MODULE of deployment \"GrailApp-0.1.war\""}}

      09:37:33,722 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-3) Stopped deployment GrailApp-0.1.war in 152ms

        • 1. Re: Grails on JBoss AS 7.0.2 Final
          jaikiran pai Master

          That was fixed in 7.1.0 versions. Try the latest 7.1.0.CR1b release

          1 of 1 people found this helpful
          • 2. Re: Grails on JBoss AS 7.0.2 Final
            Gary Quinn Newbie

            Thanks for the quick reply

             

            I'm getting another error. Looks like a servlet version issue:

             

            12:33:03,743 ERROR [org.jboss.osgi.framework.internal.FrameworkEventsPlugin] (MSC service thread 1-1) Framework ERROR: org.osgi.framework.BundleException: Cannot resolve bundle resModule: [GrailApp:0.1.0]

                      at org.jboss.osgi.framework.internal.ResolverPlugin.resolve(ResolverPlugin.java:157) [jbosgi-framework-core-1.1.0.jar:1.1.0]

                      at org.jboss.osgi.framework.internal.AbstractBundleState.ensureResolved(AbstractBundleState.java:551) [jbosgi-framework-core-1.1.0.jar:1.1.0]

                      at org.jboss.osgi.framework.internal.HostBundleState.startInternal(HostBundleState.java:211) [jbosgi-framework-core-1.1.0.jar:1.1.0]

                      at org.jboss.osgi.framework.internal.AbstractBundleState.start(AbstractBundleState.java:494) [jbosgi-framework-core-1.1.0.jar:1.1.0]

                      at org.jboss.as.osgi.deployment.BundleStartTracker$1.processService(BundleStartTracker.java:144) [jboss-as-osgi-service-7.1.0.CR1b.jar:7.1.0.CR1b]

                      at org.jboss.as.osgi.deployment.BundleStartTracker$1.transition(BundleStartTracker.java:119) [jboss-as-osgi-service-7.1.0.CR1b.jar:7.1.0.CR1b]

                      at org.jboss.msc.service.ServiceControllerImpl.invokeListener(ServiceControllerImpl.java:1429) [jboss-msc-1.0.1.GA.jar:1.0.1.GA]

                      at org.jboss.msc.service.ServiceControllerImpl.access$2600(ServiceControllerImpl.java:49) [jboss-msc-1.0.1.GA.jar:1.0.1.GA]

                      at org.jboss.msc.service.ServiceControllerImpl$ListenerTask.run(ServiceControllerImpl.java:1952) [jboss-msc-1.0.1.GA.jar:1.0.1.GA]

                      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [:1.6.0_30]

                      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [:1.6.0_30]

                      at java.lang.Thread.run(Thread.java:662) [:1.6.0_30]

            Caused by: org.jboss.osgi.resolver.XResolverException: Unable to resolve Module[GrailApp:0.1.0]: missing requirement [Module[GrailApp:0.1.0]] package; (&(package=javax.servlet)(version>=2.4.0)(!(version>=3.0.0)))

                      at org.jboss.osgi.resolver.felix.FelixResolver.resolveInternal(FelixResolver.java:117) [jbosgi-resolver-felix-1.0.10.jar:1.0.10]

                      at org.jboss.osgi.resolver.spi.AbstractResolver.resolve(AbstractResolver.java:148) [jbosgi-resolver-spi-1.0.10.jar:1.0.10]

                      at org.jboss.osgi.framework.internal.ResolverPlugin.resolve(ResolverPlugin.java:155) [jbosgi-framework-core-1.1.0.jar:1.1.0]

                      ... 11 more

             

             

            12:33:03,746 ERROR [org.jboss.as.osgi] (MSC service thread 1-1) JBAS011912: Cannot start bundle: GrailApp:0.1.0: org.osgi.framework.BundleException: Cannot resolve bundle: GrailApp:0.1.0

                      at org.jboss.osgi.framework.internal.HostBundleState.startInternal(HostBundleState.java:212) [jbosgi-framework-core-1.1.0.jar:1.1.0]

                      at org.jboss.osgi.framework.internal.AbstractBundleState.start(AbstractBundleState.java:494) [jbosgi-framework-core-1.1.0.jar:1.1.0]

                      at org.jboss.as.osgi.deployment.BundleStartTracker$1.processService(BundleStartTracker.java:144) [jboss-as-osgi-service-7.1.0.CR1b.jar:7.1.0.CR1b]

                      at org.jboss.as.osgi.deployment.BundleStartTracker$1.transition(BundleStartTracker.java:119) [jboss-as-osgi-service-7.1.0.CR1b.jar:7.1.0.CR1b]

                      at org.jboss.msc.service.ServiceControllerImpl.invokeListener(ServiceControllerImpl.java:1429) [jboss-msc-1.0.1.GA.jar:1.0.1.GA]

                      at org.jboss.msc.service.ServiceControllerImpl.access$2600(ServiceControllerImpl.java:49) [jboss-msc-1.0.1.GA.jar:1.0.1.GA]

                      at org.jboss.msc.service.ServiceControllerImpl$ListenerTask.run(ServiceControllerImpl.java:1952) [jboss-msc-1.0.1.GA.jar:1.0.1.GA]

                      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [:1.6.0_30]

                      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [:1.6.0_30]

                      at java.lang.Thread.run(Thread.java:662) [:1.6.0_30]

             

             

            12:33:03,746 ERROR [GrailApp] (Thread-70) FrameworkEvent ERROR: org.apache.felix.log.LogException: org.osgi.framework.BundleException: Cannot resolve bundle resModule: [GrailApp:0.1.0]

                      at org.jboss.osgi.framework.internal.ResolverPlugin.resolve(ResolverPlugin.java:157)

                      at org.jboss.osgi.framework.internal.AbstractBundleState.ensureResolved(AbstractBundleState.java:551)

                      at org.jboss.osgi.framework.internal.HostBundleState.startInternal(HostBundleState.java:211)

                      at org.jboss.osgi.framework.internal.AbstractBundleState.start(AbstractBundleState.java:494)

                      at org.jboss.as.osgi.deployment.BundleStartTracker$1.processService(BundleStartTracker.java:144)

                      at org.jboss.as.osgi.deployment.BundleStartTracker$1.transition(BundleStartTracker.java:119)

                      at org.jboss.msc.service.ServiceControllerImpl.invokeListener(ServiceControllerImpl.java:1429)

                      at org.jboss.msc.service.ServiceControllerImpl.access$2600(ServiceControllerImpl.java:49)

                      at org.jboss.msc.service.ServiceControllerImpl$ListenerTask.run(ServiceControllerImpl.java:1952)

                      at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [:1.6.0_30]

                      at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [:1.6.0_30]

                      at java.lang.Thread.run(Thread.java:662) [:1.6.0_30]

            Caused by: org.apache.felix.log.LogException: org.jboss.osgi.resolver.XResolverException: Unable to resolve Module[GrailApp:0.1.0]: missing requirement [Module[GrailApp:0.1.0]] package; (&(package=javax.servlet)(version>=2.4.0)(!(version>=3.0.0)))

                      at org.jboss.osgi.resolver.felix.FelixResolver.resolveInternal(FelixResolver.java:117)

                      at org.jboss.osgi.resolver.spi.AbstractResolver.resolve(AbstractResolver.java:148)

                      at org.jboss.osgi.framework.internal.ResolverPlugin.resolve(ResolverPlugin.java:155)

                      ... 11 more

             

             

            12:33:03,755 INFO  [org.jboss.as.server] (HttpManagementService-threads - 6) JBAS018559: Deployed "GrailApp-0.1.war"

            • 4. Re: Grails on JBoss AS 7.0.2 Final
              Thomas Diesler Master

              The generated grails bundle is invalid. For details please see AS7-2941