1 Reply Latest reply on Jan 15, 2012 1:23 PM by Radoslav Husar

    Jboss AS7 Domain with modcluster

    christoph langer Newbie

      AlI`ve managed to get a jboss domain up and running. The domain now has 2 servers, to keep things simple for the start the first server has the host controller and one host with one server. The second server has one host as well with one server installed. It will get 5 Servers with different zones / deployment so the domain mode makes sense.

       

      I had to deal with different kind of memory errors and some problems with the binding of the interfaces and authentification but finally i was able to deploy my application which uses seam3 / jboss as 7.1CR1.

       

      If i use mod_proxy and pass through to the two installed servers everything works fine, of course this is not a cluster, its 2 servers running in cluster mode with a direct access. I tried this to make sure everything is up and running.

       

      the ha profile is used, the hosts register with the host controller.

       

      Apache has mod_cluster 1.1.3 is installed, the cluster status shows one of the 2 hosts connected to the cluster. The second node does not appear at all. The deployed zone is listed and enabled. The hostname which is  used in apache was added to the jboss host aliases. The hostname is also listed.

       

      If i try to access the zone i get an error

      proxy: No protocol handler was valid for the URL /shop/. If you are using a DSO version of mod_proxy, make sure the proxy submodules are included in the configuration using LoadModule

       

      If i try to access modcluster with the jbossadmin tools i cannot get to the module at all. How is this done in domain mode?

      i use jboss-admin.sh

      i am connected to domain@192.168.50.100:999

       

      subsystem=modcluster/:list-proxies  is not working at all.

       

      After reading tons of posts, docus i am stuck, i even bought the new as7 book which has a nice chapter about clustering but afterall it did not help very much.

       

      Anybody has an idea or a link to a setup that is working.

       

      apache config:

      Listen 192.168.50.100:8888

      <VirtualHost 192.168.50.100:8888>

          <Location />

              Order deny,allow

              Deny from all

              Allow from 192.168.50.

          </Location>

         KeepAliveTimeout 60

         MaxKeepAliveRequests 0

         ManagerBalancerName mycluster

         ServerAdvertise On

      </VirtualHost>

       

      output of mod_cluster_manager

      start of "httpd.conf" configuration

      mod_proxy_cluster.c: OK

      mod_sharedmem.c: OK

      Protocol supported: AJP

      mod_advertise.c: OK

      Node aaa-aaa-aaa (http://192.168.50.100:8080)

      Balancer: mycluster,LBGroup: ,Flushpackets: Off,Flushwait: 10000,Ping: 10000000,Smax: 26,Ttl: 60000000,Status: OK,Elected: 4,Read: 0,Transferred: 0,Connected: 0,Load: 1

      Virtual Host 1:

      Contexts:

      /test, Status: ENABLED

      Aliases: localhost

      real.host.name

       

      the jboss domain controller registers the cluster client

      [org.jboss.modcluster.ModClusterService] (ContainerBackgroundProcessor[StandardEngine[jboss.web]]) Engine [jboss.web] will use jvmRoute: aaa-aaa-aaa

       

      any suggestions?

       

      I will post a complete setup after completion.

       

      thank you

       

      I`ve just tried the default installation of jboss 7.0.2, activated the ha profile and changed the interface adresses.

      Same sympthoms than in 7.1CR1, one server connects to the apache mod_cluster, mod_server_manager shows connection and deployed zone.

      access is not possible, same error as above.

      Seems like a problem with modcluster and not the domain / jboss setup.

        • 1. Re: Jboss AS7 Domain with modcluster
          Radoslav Husar Master

          Hi Christoph,

           

          first of there are are still some issues, mod_cluster subsystem is undergoing update to 1.2 so issues are anticipated.

           

          For instance see here https://issues.jboss.org/browse/AS7-3194 -- issue with a domain mode.

          i am connected to domain@192.168.50.100:999

           

          subsystem=modcluster/:list-proxies  is not working at all.

          This does not exist. When you are connected to domain there is no such thing as subsystem in root as you are managing a domain not a single server instance. If you want to look at operations call :read-operation-names or use tab completion. You need to :

           

          cd /profile=ha/subsystem=modcluster

           

          or  server's runtime is

           

          cd /host=master/server=server-one/subsystem=modcluster

           

          and make sure its running the HA profile.

           

          HTH,

          Rado