7 Replies Latest reply on Jan 17, 2012 1:55 AM by Yong Hao Gao

    hornetq-jms.xml entries not honoured after jmx createQueue call

    Hugh Bragg Newbie

      After upgrading to 2.2.5, I deleted the data directory and started hornetq standalone non clustered.

      Everything was fine and all my hornetq-jms.xml entries were created as expected. It ran fine for 2 weeks.

      I wanted to do some loadtesting comparing different instances of hornetq so I tried to add some more queues to the jms file.

      It didn't work as I'd expected by creating the queues I'd added to the file like it used to in 2.1.2.

       

      I ran jconsole and connected, everything was there from the original jms file, butr none of the new entries.

      I added a queue manually by calling createQueue("queueName", "/queue/queueName") from jconsole

      It created the queue as expected.

       

      I restarted Hornetq and ran jconsole again. The only queue was the one I'd created using createQueue.

      None of the queues from the jms file were there, not the old ones or the new ones. All the old ones were still in the core queues, but not the jms queues.

       

      I stopped hornetq and deleted the data directory, but when I restarted all the address and queue entries were missing.

      I was able to restore the old data directory and get back to where I was before I deleted it, but now I'm left in the position that I can't create the old or new queues without explicitly calling createQueue.

       

      The old behavious very useful as I could add queues without restarting and they were persistant across restarts.

       

      Is this a bug?

      Is there another way to do this or have I made a mistake?

      How can I copy my configuration to another machine now that it ignores hornetq-jms.xml?

       

      I started this old thread long ago which was when I discovered the behaviour.

      https://community.jboss.org/thread/167164